Skip Menu |
 

This queue is for tickets about the libwww-perl CPAN distribution.

Report information
The Basics
Id: 102119
Status: resolved
Priority: 0/
Queue: libwww-perl

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 6.12
Fixed in: 6.13



Subject: Not an ARRAY reference at Makefile.PL line 110.
Download (untitled) / with headers
text/plain 253b
Running Makefile.PL with EUMM 6.63_02 installed fails with "Not an ARRAY reference at Makefile.PL line 110.". That's because TEST_REQUIRES is a hash reference, not an array reference. Maybe the compat code for BUILD_REQUIRES and PREREQ_PM is wrong, too.
Download (untitled) / with headers
text/plain 416b
On 2015-02-14 04:45:26, SREZIC wrote: Show quoted text
> Running Makefile.PL with EUMM 6.63_02 installed fails with "Not an > ARRAY reference at Makefile.PL line 110.". That's because > TEST_REQUIRES is a hash reference, not an array reference. Maybe the > compat code for BUILD_REQUIRES and PREREQ_PM is wrong, too.
A cpantesters report with this problem: http://www.cpantesters.org/cpan/report/7030a740-6bf5-1014-961d-f3a0cb12e6cd
Download (untitled) / with headers
text/plain 351b
On 2015-02-14 01:45:26, SREZIC wrote: Show quoted text
> Running Makefile.PL with EUMM 6.63_02 installed fails with "Not an > ARRAY reference at Makefile.PL line 110.". That's because > TEST_REQUIRES is a hash reference, not an array reference. Maybe the > compat code for BUILD_REQUIRES and PREREQ_PM is wrong, too.
Doh, I meant to copy a hash slice. Fixed in 6.13.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.