Skip Menu |
 

This queue is for tickets about the Error CPAN distribution.

Report information
The Basics
Id: 102062
Status: resolved
Priority: 0/
Queue: Error

People
Owner: Nobody in particular
Requestors: quanah.gibsonmount [...] gmail.com
SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.17022
Fixed in: (no value)



Subject: Error requirement for Module::Build is excessively high
Download (untitled) / with headers
text/plain 102b
Error requires Module::Build 0.39, but builds just fine with versions as old as Module::Build 0.280801
Download (untitled) / with headers
text/plain 633b
Hi MISHIKAL, On Tue Feb 10 19:04:38 2015, MISHIKAL wrote: Show quoted text
> Error requires Module::Build 0.39, but builds just fine with versions > as old as Module::Build 0.280801
First of all, it's not hard to upgrade Module::Build, so it should not be an issue. «Real programmers don’t write workarounds. They tell their users to upgrade their software.» (see http://www.shlomifish.org/humour.html#real_programmers_dont_write - something I said once). Second of all, I should note that Error.pm is in itself deprecated and in deep maintenance mode, so you should try to avoid it, to begin with. REJECTing. Sorry! Regards, -- Shlomi Fish
Download (untitled) / with headers
text/plain 1.1k
On Wed Feb 11 02:17:15 2015, SHLOMIF wrote: Show quoted text
> First of all, it's not hard to upgrade Module::Build, so it should not > be an issue. «Real programmers don’t write workarounds. They tell > their users to upgrade their software.» (see > http://www.shlomifish.org/humour.html#real_programmers_dont_write - > something I said once).
A) It's not a workaround. Your module has an unreasonably high version requirement on Module::Build that is utterly unnecessary B) Replacing Module::Build is not as simple as you believe. It ends up pulling in about 15 other modules, including other core modules, as replacements, with absolutely ZERO NEED for this to be done. This is a major flaw in the packaging of your module, not a use the latest and greatest issue. Show quoted text
> Second of all, I should note that Error.pm is in itself deprecated and > in deep maintenance mode, so you should try to avoid it, to begin > with.
I would be happy not to use Error. However, it's used by Mail::SPF, which is used by Mail::SpamAssassin, which is my ultimate build goal. I.e., *I* have no personal control over the unfortunate usage of your Error module by the Mail::SPF author.
Download (untitled) / with headers
text/plain 934b
On Thu Feb 12 12:53:24 2015, MISHIKAL wrote: Show quoted text
> On Wed Feb 11 02:17:15 2015, SHLOMIF wrote: >
> > First of all, it's not hard to upgrade Module::Build, so it should > > not > > be an issue. «Real programmers don’t write workarounds. They tell > > their users to upgrade their software.» (see > > http://www.shlomifish.org/humour.html#real_programmers_dont_write - > > something I said once).
> > A) It's not a workaround. Your module has an unreasonably high > version requirement on Module::Build that is utterly unnecessary > > B) Replacing Module::Build is not as simple as you believe. It ends > up pulling in about 15 other modules, including other core modules, as > replacements, with absolutely ZERO NEED for this to be done. This is > a major flaw in the packaging of your module, not a use the latest and > greatest issue. > >
OK, this is fixed in Error-0.17023. Thanks for the report! REgards, -- Shlomi Fish


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.