This queue is for tickets about the Text-CSV_XS CPAN distribution.

Report information
The Basics
Id:
102053
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
TEAM [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
0.68
Fixed in:
1.15



Subject: CPAN.pm recommends_policy < perl-5.20.1
Hi there, Currently this module lists the latest Perl version as a recommended dependency. Not sure if this is due to specific issues in older versions of perl, but it doesn't play very well with the CPAN.pm 'recommends_policy' option. Using these two lines from cpan on pre-5.20.1 versions of perl will fail installation: o conf recommends_policy 1 install Text::CSV_XS Arguably that's a fault with CPAN.pm, and it should provide better control over that feature (ignore recommended, install if available, always install), so I'll raise that separately. However, it might reduce confusion if that perl version line was removed? (https://github.com/Tux/Text-CSV_XS/blob/master/sandbox/genMETA.pl#L55) This would at least allow people to install without them needing to disable the recommends_policy setting. I haven't tested with other CPAN clients, so I don't know if this applies to cpanm etc. thanks, Tom


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.