Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 101664
Status: open
Priority: 0/
Queue: Net-SSLeay

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.67
Fixed in: (no value)



Subject: Installation failure on 5.21.8
Download (untitled) / with headers
text/plain 9.5k
This is darwin (OSX version 10.8). build.log below... Searching Net::SSLeay on cpanmetadb ... --> Working on Net::SSLeay Fetching http://www.cpan.org/authors/id/M/MI/MIKEM/Net-SSLeay-1.67.tar.gz -> OK Unpacking Net-SSLeay-1.67.tar.gz Entering Net-SSLeay-1.67 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 6.36 ... Yes (7.04) Configuring Net-SSLeay-1.67 Running Makefile.PL *** Found OpenSSL-0.9.8z installed in /usr *** Be sure to use the same compiler and options to compile your OpenSSL, perl, and Net::SSLeay. Mixing and matching compilers is not supported. Do you want to run external tests? These tests *will* *fail* if you do not have network connectivity. [n] n Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Net::SSLeay Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.json ... Checking if you have MIME::Base64 0 ... Yes (3.15) Checking if you have ExtUtils::MakeMaker 6.36 ... Yes (7.04) Checking if you have Test::More 0.60_01 ... Yes (1.301001_097) Building and testing Net-SSLeay-1.67 AutoSplitting blib/lib/Net/SSLeay.pm (blib/lib/auto/Net/SSLeay) blib/lib/Net/SSLeay.pm: some names are not unique when truncated to 8 characters: directory blib/lib/auto/Net/SSLeay: do_https3.al, do_https2.al, do_https4.al, do_https.al truncate to do_https do_httpx3.al, do_httpx2.al, do_httpx4.al truncate to do_httpx get_https.al, get_https3.al, get_https4.al, get_http.al, get_http3.al, get_http4.al, get_httpx.al, get_httpx3.al, get_httpx4.al truncate to get_http head_https.al, head_https3.al, head_https4.al, head_http.al, head_http3.al, head_http4.al, head_httpx.al, head_httpx3.al, head_httpx4.al truncate to head_htt post_https.al, post_https3.al, post_https4.al, post_http.al, post_http3.al, post_http4.al, post_httpx.al, post_httpx3.al, post_httpx4.al truncate to post_htt put_https.al, put_https3.al, put_https4.al, put_http.al, put_http3.al, put_http4.al, put_httpx.al, put_httpx3.al, put_httpx4.al truncate to put_http ssl_read_all.al, ssl_read_until.al, ssl_read_CRLF.al truncate to ssl_read ssl_write_all.al, ssl_write_CRLF.al truncate to ssl_writ tcp_read_all.al, tcp_read_until.al, tcp_read_CRLF.al truncate to tcp_read tcp_write_all.al, tcp_write_CRLF.al truncate to tcp_writ Running Mkbootstrap for Net::SSLeay () chmod 644 "SSLeay.bs" "/Users/ether/perl5/perlbrew/perls/21.8/bin/perl5.21.8" "-Iinc" "/Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/ExtUtils/xsubpp" -typemap "/Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/ExtUtils/typemap" -typemap "typemap" SSLeay.xs > SSLeay.xsc && mv SSLeay.xsc SSLeay.c cc -c -I/usr/include -fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack-protector -I/opt/local/include -O3 -DVERSION=\"1.67\" -DXS_VERSION=\"1.67\" "-I/Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE" SSLeay.c SSLeay.xs:490:9: warning: expression result unused [-Wunused-value] hv_store(MY_CXT.global_cb_data, key_name, strlen(key_name), newRV_noinc((SV*)L2HV), 0); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:505:13: warning: expression result unused [-Wunused-value] hv_store(L2HV, data_name, strlen(data_name), data, 0); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:502:5: warning: expression result unused [-Wunused-value] hv_delete(L2HV, data_name, strlen(data_name), G_DISCARD); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:487:6: note: expanded from macro 'hv_delete' (MUTABLE_SV(hv_common_key_len((hv), (key), (klen), \ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/handy.h:74:24: note: expanded from macro 'MUTABLE_SV' #define MUTABLE_SV(p) ((SV *)MUTABLE_PTR(p)) ^ ~~~~~~~~~~~~~~ SSLeay.xs:549:5: warning: expression result unused [-Wunused-value] hv_delete(MY_CXT.global_cb_data, key_name, strlen(key_name), G_DISCARD); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:487:6: note: expanded from macro 'hv_delete' (MUTABLE_SV(hv_common_key_len((hv), (key), (klen), \ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/handy.h:74:24: note: expanded from macro 'MUTABLE_SV' #define MUTABLE_SV(p) ((SV *)MUTABLE_PTR(p)) ^ ~~~~~~~~~~~~~~ SSLeay.xs:5741:28: warning: expression result unused [-Wunused-value] if (sir->nextUpdate) hv_store(details,"nextUpdate",10, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:5743:28: warning: expression result unused [-Wunused-value] if (sir->thisUpdate) hv_store(details,"thisUpdate",10, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:5747:4: warning: expression result unused [-Wunused-value] hv_store(details,"revocationTime",14,newSViv( ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:5749:4: warning: expression result unused [-Wunused-value] hv_store(details,"revocationReason",16,newSViv( ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:5751:4: warning: expression result unused [-Wunused-value] hv_store(details,"revocationReason_str",20,newSVpv( ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SSLeay.xs:5739:7: warning: expression result unused [-Wunused-value] hv_store(details,"statusType",10, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:473:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), (key), (klen), \ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 10 warnings generated. rm -f blib/arch/auto/Net/SSLeay/SSLeay.bundle LD_RUN_PATH="/usr/lib" env MACOSX_DEPLOYMENT_TARGET=10.3 cc -bundle -undefined dynamic_lookup -L/usr -L/usr/lib -L/opt/local/lib -fstack-protector SSLeay.o -o blib/arch/auto/Net/SSLeay/SSLeay.bundle \ -L/usr -L/usr/lib -lssl -lcrypto -lz \ chmod 755 blib/arch/auto/Net/SSLeay/SSLeay.bundle "/Users/ether/perl5/perlbrew/perls/21.8/bin/perl5.21.8" "-Iinc" -MExtUtils::Command::MM -e 'cp_nonempty' -- SSLeay.bs blib/arch/auto/Net/SSLeay/SSLeay.bs 644 Manifying 2 pod documents Running Mkbootstrap for Net::SSLeay () chmod 644 "SSLeay.bs" PERL_DL_NONLAZY=1 "/Users/ether/perl5/perlbrew/perls/21.8/bin/perl5.21.8" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/local/*.t t/handle/local/*.t t/local/01_pod.t ....................... skipped: Test::Pod 1.00 required for testing POD t/local/02_pod_coverage.t .............. skipped: these tests are for only for release candidate testing. Enable with RELEASE_TESTING=1 # Failed test 'use Net::SSLeay::Handle;' # at t/handle/local/05_use.t line 8. # Tried to use 'Net::SSLeay::Handle'. # Error: Can't load '/Users/ether/.cpanm/work/1421863826.72120/Net-SSLeay-1.67/blib/arch/auto/Net/SSLeay/SSLeay.bundle' for module Net::SSLeay: dlopen(/Users/ether/.cpanm/work/1421863826.72120/Net-SSLeay-1.67/blib/arch/auto/Net/SSLeay/SSLeay.bundle, 2): Symbol not found: _EVP_MD_do_all_sorted # Referenced from: /Users/ether/.cpanm/work/1421863826.72120/Net-SSLeay-1.67/blib/arch/auto/Net/SSLeay/SSLeay.bundle # Expected in: dynamic lookup #
Download (untitled) / with headers
text/plain 161b
Looks like the build.log got truncated. I'm attaching the whole thing (includes other modules as well -- first module installations on a brand new 5.21.8 build).
Subject: build.log
Download build.log
application/octet-stream 188k

Message body not shown because it is not plain text.

OpenSSL 1.0.1j 15 Oct 2014 from macports.
Download (untitled) / with headers
text/plain 179b
On 2015-01-21 10:51:44, ETHER wrote: Show quoted text
> OpenSSL 1.0.1j 15 Oct 2014 > from macports.
I updated to OpenSSL 1.0.1k 8 Jan 2015 and still get: "Symbol not found: _EVP_MD_do_all_sorted"
Download (untitled) / with headers
text/plain 342b
On 2015-01-21 14:11:05, ETHER wrote: Show quoted text
> On 2015-01-21 10:51:44, ETHER wrote:
> > OpenSSL 1.0.1j 15 Oct 2014 > > from macports.
> > I updated to OpenSSL 1.0.1k 8 Jan 2015 and still get: "Symbol not > found: _EVP_MD_do_all_sorted"
Just a data point: there are pass reports with 5.21.8, see http://matrix.cpantesters.org/?dist=Net-SSLeay%201.67
Download (untitled) / with headers
text/plain 238b
Show quoted text
> Just a data point: there are pass reports with 5.21.8, see > http://matrix.cpantesters.org/?dist=Net-SSLeay%201.67
None on darwin though.. I went back to my 5.21.6 and 5.21.7 installs and see the same failure (test reports submitted).
Download (untitled) / with headers
text/plain 381b
On 2015-01-21 12:02:47, ETHER wrote: Show quoted text
>
> > Just a data point: there are pass reports with 5.21.8, see > > http://matrix.cpantesters.org/?dist=Net-SSLeay%201.67
> > None on darwin though.. > I went back to my 5.21.6 and 5.21.7 installs and see the same failure > (test reports submitted).
1.67 fails on all perlbrews I have installed; reports have been submitted for all of them.
Subject: Re: [rt.cpan.org #101664] Installation failure on 5.21.8
Date: Thu, 22 Jan 2015 08:39:57 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 10.4k
Hello. Tests here with Net-SSLeay 1.67 and macports openssl 1.0.1k and perl 5.18 (standard with Yosemite) are successful. What perl are you using (I know its perl 5.21 I mean how did you install it, so I can reproduce your report) Cheers. On Wednesday, January 21, 2015 01:21:04 PM you wrote: Show quoted text
> Wed Jan 21 13:21:02 2015: Request 101664 was acted upon. > Transaction: Ticket created by ETHER > Queue: Net-SSLeay > Subject: Installation failure on 5.21.8 > Broken in: (no value) > Severity: Critical > Owner: Nobody > Requestors: ether@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > > > This is darwin (OSX version 10.8). > > build.log below... > > > Searching Net::SSLeay on cpanmetadb ... > --> Working on Net::SSLeay > Fetching http://www.cpan.org/authors/id/M/MI/MIKEM/Net-SSLeay-1.67.tar.gz > -> OK > Unpacking Net-SSLeay-1.67.tar.gz > Entering Net-SSLeay-1.67 > Checking configure dependencies from META.yml > Checking if you have ExtUtils::MakeMaker 6.36 ... Yes (7.04) > Configuring Net-SSLeay-1.67 > Running Makefile.PL > *** Found OpenSSL-0.9.8z installed in /usr > *** Be sure to use the same compiler and options to compile your OpenSSL, > perl, and Net::SSLeay. Mixing and matching compilers is not supported. Do > you want to run external tests? > These tests *will* *fail* if you do not have network connectivity. [n] n > Checking if your kit is complete... > Looks good > Generating a Unix-style Makefile > Writing Makefile for Net::SSLeay > Writing MYMETA.yml and MYMETA.json > -> OK > Checking dependencies from MYMETA.json ... > Checking if you have MIME::Base64 0 ... Yes (3.15) > Checking if you have ExtUtils::MakeMaker 6.36 ... Yes (7.04) > Checking if you have Test::More 0.60_01 ... Yes (1.301001_097) > Building and testing Net-SSLeay-1.67 > AutoSplitting blib/lib/Net/SSLeay.pm (blib/lib/auto/Net/SSLeay) > blib/lib/Net/SSLeay.pm: some names are not unique when truncated to 8 > characters: directory blib/lib/auto/Net/SSLeay: > do_https3.al, do_https2.al, do_https4.al, do_https.al truncate to do_https > do_httpx3.al, do_httpx2.al, do_httpx4.al truncate to do_httpx > get_https.al, get_https3.al, get_https4.al, get_http.al, get_http3.al, > get_http4.al, get_httpx.al, get_httpx3.al, get_httpx4.al truncate to > get_http head_https.al, head_https3.al, head_https4.al, head_http.al, > head_http3.al, head_http4.al, head_httpx.al, head_httpx3.al, head_httpx4.al > truncate to head_htt post_https.al, post_https3.al, post_https4.al, > post_http.al, post_http3.al, post_http4.al, post_httpx.al, post_httpx3.al, > post_httpx4.al truncate to post_htt put_https.al, put_https3.al, > put_https4.al, put_http.al, put_http3.al, put_http4.al, put_httpx.al, > put_httpx3.al, put_httpx4.al truncate to put_http ssl_read_all.al, > ssl_read_until.al, ssl_read_CRLF.al truncate to ssl_read ssl_write_all.al, > ssl_write_CRLF.al truncate to ssl_writ > tcp_read_all.al, tcp_read_until.al, tcp_read_CRLF.al truncate to tcp_read > tcp_write_all.al, tcp_write_CRLF.al truncate to tcp_writ > Running Mkbootstrap for Net::SSLeay () > chmod 644 "SSLeay.bs" > "/Users/ether/perl5/perlbrew/perls/21.8/bin/perl5.21.8" "-Iinc" > "/Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/ExtUtils/xsubpp" > -typemap > "/Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/ExtUtils/typemap" > -typemap "typemap" SSLeay.xs > SSLeay.xsc && mv SSLeay.xsc SSLeay.c cc -c > -I/usr/include -fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe > -fstack-protector -I/opt/local/include -O3 -DVERSION=\"1.67\" > -DXS_VERSION=\"1.67\" > "-I/Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE" > SSLeay.c SSLeay.xs:490:9: warning: expression result unused > [-Wunused-value] hv_store(MY_CXT.global_cb_data, key_name, > strlen(key_name), newRV_noinc((SV*)L2HV), 0); > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > ~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:4 > 73:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:505:13: warning: expression result unused [-Wunused-value] > hv_store(L2HV, data_name, strlen(data_name), data, 0); > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:47 > 3:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:502:5: warning: expression result unused [-Wunused-value] > hv_delete(L2HV, data_name, strlen(data_name), G_DISCARD); > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:48 > 7:6: note: expanded from macro 'hv_delete' > (MUTABLE_SV(hv_common_key_len((hv), (key), (klen), \ > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/handy. > h:74:24: note: expanded from macro 'MUTABLE_SV' #define MUTABLE_SV(p) ((SV > *)MUTABLE_PTR(p)) > ^ ~~~~~~~~~~~~~~ > SSLeay.xs:549:5: warning: expression result unused [-Wunused-value] > hv_delete(MY_CXT.global_cb_data, key_name, strlen(key_name), G_DISCARD); > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:4 > 87:6: note: expanded from macro 'hv_delete' > (MUTABLE_SV(hv_common_key_len((hv), (key), (klen), \ > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/handy. > h:74:24: note: expanded from macro 'MUTABLE_SV' #define MUTABLE_SV(p) ((SV > *)MUTABLE_PTR(p)) > ^ ~~~~~~~~~~~~~~ > SSLeay.xs:5741:28: warning: expression result unused [-Wunused-value] > if (sir->nextUpdate) hv_store(details,"nextUpdate",10, > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:47 > 3:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:5743:28: warning: expression result unused [-Wunused-value] if > (sir->thisUpdate) hv_store(details,"thisUpdate",10, > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:4 > 73:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:5747:4: warning: expression result unused [-Wunused-value] > hv_store(details,"revocationTime",14,newSViv( > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:4 > 73:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:5749:4: warning: expression result unused [-Wunused-value] > hv_store(details,"revocationReason",16,newSViv( > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:4 > 73:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:5751:4: warning: expression result unused [-Wunused-value] > hv_store(details,"revocationReason_str",20,newSVpv( > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:4 > 73:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > SSLeay.xs:5739:7: warning: expression result unused [-Wunused-value] > hv_store(details,"statusType",10, > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > /Users/ether/perl5/perlbrew/perls/21.8/lib/5.21.8/darwin-2level/CORE/hv.h:47 > 3:6: note: expanded from macro 'hv_store' ((SV**) hv_common_key_len((hv), > (key), (klen), \ ^ > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 10 warnings > generated. > rm -f blib/arch/auto/Net/SSLeay/SSLeay.bundle > LD_RUN_PATH="/usr/lib" env MACOSX_DEPLOYMENT_TARGET=10.3 cc -bundle > -undefined dynamic_lookup -L/usr -L/usr/lib -L/opt/local/lib > -fstack-protector SSLeay.o -o blib/arch/auto/Net/SSLeay/SSLeay.bundle \ > -L/usr -L/usr/lib -lssl -lcrypto -lz \ > > chmod 755 blib/arch/auto/Net/SSLeay/SSLeay.bundle > "/Users/ether/perl5/perlbrew/perls/21.8/bin/perl5.21.8" "-Iinc" > -MExtUtils::Command::MM -e 'cp_nonempty' -- SSLeay.bs > blib/arch/auto/Net/SSLeay/SSLeay.bs 644 Manifying 2 pod documents > Running Mkbootstrap for Net::SSLeay () > chmod 644 "SSLeay.bs" > PERL_DL_NONLAZY=1 "/Users/ether/perl5/perlbrew/perls/21.8/bin/perl5.21.8" > "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef > *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" > t/local/*.t t/handle/local/*.t t/local/01_pod.t ....................... > skipped: Test::Pod 1.00 required for testing POD t/local/02_pod_coverage.t > .............. skipped: these tests are for only for release candidate > testing. Enable with RELEASE_TESTING=1 > > # Failed test 'use Net::SSLeay::Handle;' > # at t/handle/local/05_use.t line 8. > # Tried to use 'Net::SSLeay::Handle'. > # Error: Can't load > '/Users/ether/.cpanm/work/1421863826.72120/Net-SSLeay-1.67/blib/arch/auto/N > et/SSLeay/SSLeay.bundle' for module Net::SSLeay: > dlopen(/Users/ether/.cpanm/work/1421863826.72120/Net-SSLeay-1.67/blib/arch/ > auto/Net/SSLeay/SSLeay.bundle, 2): Symbol not found: _EVP_MD_do_all_sorted # > Referenced from: > /Users/ether/.cpanm/work/1421863826.72120/Net-SSLeay-1.67/blib/arch/auto/Ne > t/SSLeay/SSLeay.bundle # Expected in: dynamic lookup > #
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Download (untitled) / with headers
text/plain 581b
On 2015-01-21 14:40:14, mikem@airspayce.com wrote: Show quoted text
> Hello. > > Tests here with Net-SSLeay 1.67 and macports openssl 1.0.1k and perl > 5.18 > (standard with Yosemite) are successful. > > What perl are you using (I know its perl 5.21 I mean how did you > install it, > so I can reproduce your report)
I install my perls with perlbrew with this script: https://github.com/karenetheridge/misc/blob/master/install/generic/bin/newperl whihc boils down to: perlbrew install -j 9 --as 21.8 5.21.8 -D man1dir=none -D man3dir=none perlbrew lib create 21.8@std perlbrew use 21.8@std
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Thu, 22 Jan 2015 09:16:31 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1013b
Thanks. And whence your 'perlbrew'? Cheers. On Wednesday, January 21, 2015 06:08:17 PM you wrote: Show quoted text
> Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > On 2015-01-21 14:40:14, mikem@airspayce.com wrote:
> > Hello. > > > > Tests here with Net-SSLeay 1.67 and macports openssl 1.0.1k and perl > > 5.18 > > (standard with Yosemite) are successful. > > > > What perl are you using (I know its perl 5.21 I mean how did you > > install it, > > so I can reproduce your report)
> > I install my perls with perlbrew with this script: > https://github.com/karenetheridge/misc/blob/master/install/generic/bin/newpe > rl > > whihc boils down to: > > perlbrew install -j 9 --as 21.8 5.21.8 -D man1dir=none -D man3dir=none > perlbrew lib create 21.8@std > perlbrew use 21.8@std
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Download (untitled) / with headers
text/plain 165b
On 2015-01-21 15:16:45, mikem@airspayce.com wrote: Show quoted text
> Thanks. > > And whence your 'perlbrew'?
What? The script does a self-upgrade right at the start, so it's 0.72.
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Fri, 23 Jan 2015 15:00:40 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 582b
OK, so I can now reproduce this. Working..... Cheers. On Wednesday, January 21, 2015 07:41:24 PM you wrote: Show quoted text
> Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > On 2015-01-21 15:16:45, mikem@airspayce.com wrote:
> > Thanks. > > > > And whence your 'perlbrew'?
> > What? > The script does a self-upgrade right at the start, so it's 0.72.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Fri, 23 Jan 2015 16:02:01 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 920b
Hmmm, seems that with the macports openssl installed, NetSSLeay is getting headers from macports, but libraries from the standard OSX openssl 0.9.8, which does not have EVP_MD_do_all_sorted Library order needs adjusting? Working.... On Friday, January 23, 2015 03:00:40 PM Mike McCauley wrote: Show quoted text
> OK, so I can now reproduce this. > Working..... > > Cheers. > > On Wednesday, January 21, 2015 07:41:24 PM you wrote:
> > Queue: Net-SSLeay > > > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > > > On 2015-01-21 15:16:45, mikem@airspayce.com wrote:
> > > Thanks. > > > > > > And whence your 'perlbrew'?
> > > > What? > > The script does a self-upgrade right at the start, so it's 0.72.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Fri, 23 Jan 2015 16:17:17 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.1k
OK, so I now have a fix that permits building on osx with or without macports openssl installed. Will propagate to SVN soon. Cheers. On Friday, January 23, 2015 04:02:01 PM you wrote: Show quoted text
> Hmmm, > > seems that with the macports openssl installed, NetSSLeay is getting headers > from macports, but libraries from the standard OSX openssl 0.9.8, which > does not have EVP_MD_do_all_sorted > > Library order needs adjusting? > > Working.... > > On Friday, January 23, 2015 03:00:40 PM Mike McCauley wrote:
> > OK, so I can now reproduce this. > > Working..... > > > > Cheers. > > > > On Wednesday, January 21, 2015 07:41:24 PM you wrote:
> > > Queue: Net-SSLeay > > > > > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > > > > > On 2015-01-21 15:16:45, mikem@airspayce.com wrote:
> > > > Thanks. > > > > > > > > And whence your 'perlbrew'?
> > > > > > What? > > > The script does a self-upgrade right at the start, so it's 0.72.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Sat, 24 Jan 2015 07:03:23 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.3k
Hello, This fix is now in SVN 433 If you care to test it and let me know it works I will make a new release. Cheers. On Friday, January 23, 2015 04:17:17 PM Mike McCauley wrote: Show quoted text
> OK, so I now have a fix that permits building on osx with or without > macports openssl installed. > > Will propagate to SVN soon. > > Cheers. > > On Friday, January 23, 2015 04:02:01 PM you wrote:
> > Hmmm, > > > > seems that with the macports openssl installed, NetSSLeay is getting > > headers from macports, but libraries from the standard OSX openssl 0.9.8, > > which does not have EVP_MD_do_all_sorted > > > > Library order needs adjusting? > > > > Working.... > > > > On Friday, January 23, 2015 03:00:40 PM Mike McCauley wrote:
> > > OK, so I can now reproduce this. > > > Working..... > > > > > > Cheers. > > > > > > On Wednesday, January 21, 2015 07:41:24 PM you wrote:
> > > > Queue: Net-SSLeay > > > > > > > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > > > > > > > On 2015-01-21 15:16:45, mikem@airspayce.com wrote:
> > > > > Thanks. > > > > > > > > > > And whence your 'perlbrew'?
> > > > > > > > What? > > > > The script does a self-upgrade right at the start, so it's 0.72.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Download (untitled) / with headers
text/plain 12.5k

Message body is not shown because it is too large.

Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Sat, 24 Jan 2015 08:09:57 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 12.4k

Message body is not shown because it is too large.

Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Sat, 24 Jan 2015 10:26:34 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 12.4k

Message body is not shown because it is too large.

RT-Send-CC: mikem [...] airspayce.com
Download (untitled) / with headers
text/plain 105b
On 2015-01-23 16:26:50, mikem@airspayce.com wrote: Just to follow up -- 1.68 does work well. Thank you!
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Tue, 5 May 2015 21:40:31 +0200
To: "bug-Net-SSLeay [...] rt.cpan.org" <bug-Net-SSLeay [...] rt.cpan.org>
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 313b
Thanks Karen Cheers Sent from my iPhone Show quoted text
> On 5 May 2015, at 9:06 pm, "Karen Etheridge via RT" <bug-Net-SSLeay@rt.cpan.org> wrote: > > <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > On 2015-01-23 16:26:50, mikem@airspayce.com wrote: > > Just to follow up -- 1.68 does work well. Thank you! >
Download (untitled) / with headers
text/plain 1007b
Hi, This problem still happens when I use OSX homebrew's openssl. That is: Net::SSLeay reads homebrew's openssl header: /usr/local/include/openssl/ssl.h (version openssl-1.0.1h) But, link to system openssl library: /usr/lib/libssl.0.9.8.dylib As a result, I got "Symbol not found: _EVP_MD_do_all_sorted" error. So could you modify inc/Module/Install/PRIVATE/Net/SSLeay.pm to search openssl in /usr/local first? The following patch addresses this issue. --- inc/Module/Install/PRIVATE/Net/SSLeay.pm +++ inc/Module/Install/PRIVATE/Net/SSLeay.pm @@ -179,6 +179,7 @@ sub find_openssl_prefix { } my @guesses = ( + '/usr/local/bin/openssl' => '/usr/local', # OSX homebrew openssl '/opt/local/bin/openssl' => '/opt/local', # Macports openssl '/usr/bin/openssl' => '/usr', '/usr/sbin/openssl' => '/usr', NOTE: I wonder if we should apply this modification only if $^O eq "darwin" or something. Thanks.
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Fri, 26 Jun 2015 07:57:25 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.4k
Hello, Thanks, your patch is now in SVN 447 and will apprear in the next release. Cheers. On Saturday, June 13, 2015 12:20:02 PM Shoichi Kaji via RT wrote: Show quoted text
> Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > Hi, > > This problem still happens when I use OSX homebrew's openssl. > > That is: > > Net::SSLeay reads homebrew's openssl header: > /usr/local/include/openssl/ssl.h (version openssl-1.0.1h) > > But, link to system openssl library: > /usr/lib/libssl.0.9.8.dylib > > As a result, I got "Symbol not found: _EVP_MD_do_all_sorted" error. > > So could you modify inc/Module/Install/PRIVATE/Net/SSLeay.pm > to search openssl in /usr/local first? > The following patch addresses this issue. > > --- inc/Module/Install/PRIVATE/Net/SSLeay.pm > +++ inc/Module/Install/PRIVATE/Net/SSLeay.pm > @@ -179,6 +179,7 @@ sub find_openssl_prefix { > } > > my @guesses = ( > + '/usr/local/bin/openssl' => '/usr/local', # OSX > homebrew openssl '/opt/local/bin/openssl' => '/opt/local', # > Macports openssl '/usr/bin/openssl' => '/usr', > '/usr/sbin/openssl' => '/usr', > > > NOTE: I wonder if we should apply this modification only if $^O eq "darwin" > or something. > > Thanks.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474
Download (untitled) / with headers
text/plain 1.5k
I could install Net::SSLeay 1.70 on my OSX with homebrew's openssl, and all tests passed. Thank you very much! On 2015-6月-25 木 17:57:45, mikem@airspayce.com wrote: Show quoted text
> Hello, > > Thanks, your patch is now in SVN 447 and will apprear in the next > release. > > Cheers. > > On Saturday, June 13, 2015 12:20:02 PM Shoichi Kaji via RT wrote:
> > Queue: Net-SSLeay > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > > > Hi, > > > > This problem still happens when I use OSX homebrew's openssl. > > > > That is: > > > > Net::SSLeay reads homebrew's openssl header: > > /usr/local/include/openssl/ssl.h (version openssl-1.0.1h) > > > > But, link to system openssl library: > > /usr/lib/libssl.0.9.8.dylib > > > > As a result, I got "Symbol not found: _EVP_MD_do_all_sorted" error. > > > > So could you modify inc/Module/Install/PRIVATE/Net/SSLeay.pm > > to search openssl in /usr/local first? > > The following patch addresses this issue. > > > > --- inc/Module/Install/PRIVATE/Net/SSLeay.pm > > +++ inc/Module/Install/PRIVATE/Net/SSLeay.pm > > @@ -179,6 +179,7 @@ sub find_openssl_prefix { > > } > > > > my @guesses = ( > > + '/usr/local/bin/openssl' => '/usr/local', # OSX > > homebrew openssl '/opt/local/bin/openssl' => '/opt/local', # > > Macports openssl '/usr/bin/openssl' => '/usr', > > '/usr/sbin/openssl' => '/usr', > > > > > > NOTE: I wonder if we should apply this modification only if $^O eq > > "darwin" > > or something. > > > > Thanks.
Subject: Re: [rt.cpan.org #101664] Installation failure on darwin
Date: Fri, 26 Jun 2015 22:58:16 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.9k
Thanks for the report, Cheers. On Friday, June 26, 2015 08:53:02 AM you wrote: Show quoted text
> Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > I could install Net::SSLeay 1.70 on my OSX with homebrew's openssl, > and all tests passed. > > Thank you very much! > > On 2015-6月-25 木 17:57:45, mikem@airspayce.com wrote:
> > Hello, > > > > Thanks, your patch is now in SVN 447 and will apprear in the next > > release. > > > > Cheers. > > > > On Saturday, June 13, 2015 12:20:02 PM Shoichi Kaji via RT wrote:
> > > Queue: Net-SSLeay > > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101664 > > > > > > > Hi, > > > > > > This problem still happens when I use OSX homebrew's openssl. > > > > > > That is: > > > > > > Net::SSLeay reads homebrew's openssl header: > > > /usr/local/include/openssl/ssl.h (version openssl-1.0.1h) > > > > > > But, link to system openssl library: > > > /usr/lib/libssl.0.9.8.dylib > > > > > > As a result, I got "Symbol not found: _EVP_MD_do_all_sorted" error. > > > > > > So could you modify inc/Module/Install/PRIVATE/Net/SSLeay.pm > > > to search openssl in /usr/local first? > > > The following patch addresses this issue. > > > > > > --- inc/Module/Install/PRIVATE/Net/SSLeay.pm > > > +++ inc/Module/Install/PRIVATE/Net/SSLeay.pm > > > @@ -179,6 +179,7 @@ sub find_openssl_prefix { > > > > > > } > > > > > > my @guesses = ( > > > + '/usr/local/bin/openssl' => '/usr/local', # OSX > > > homebrew openssl '/opt/local/bin/openssl' => '/opt/local', # > > > Macports openssl '/usr/bin/openssl' => '/usr', > > > > > > '/usr/sbin/openssl' => '/usr', > > > > > > NOTE: I wonder if we should apply this modification only if $^O eq > > > "darwin" > > > or something. > > > > > > Thanks.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.