Skip Menu |
 

This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id: 101605
Status: open
Priority: 0/
Queue: XML-LibXSLT

People
Owner: Nobody in particular
Requestors: d.ginev [...] jacobs-university.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: XML::LibXSLT 1.93 breaks compat with older libxslt binaries
Date: Sun, 18 Jan 2015 15:37:53 -0500
To: <bugs-XML-LibXSLT [...] rt.cpan.org>
From: Deyan Ginev <d.ginev [...] jacobs-university.de>
Dear XML::LibXSLT maintainer(s), The resolution of the maxvars feature request [1], has broken compatibility with older versions of libxslt. A notable case where this is important is the Travis build system for GitHub repositories. By default, Travis will try to use the newest XML::LibXSLT available to cpanm, while lagging behind with the libxslt package. I found myself forced to manually build libxslt-1.1.28 [2] to get the Travis build back on its feet again. The concrete problem is that the "xsltMaxVars" symbol is not available in earlier libxslt versions, I attach a log at [3]. If the break in backwards compatibility was intentional, feel free to disregard. If anyone comes here to find a way to make XML::LibXSLT build under Travis again, see [2] for my solution. Much gratitude goes to the friendly folks at the freenode #perl channel on IRC, who helped me diagnose what went haywire and what ought to be a good patch. Greetings, Deyan [1] https://rt.cpan.org/Public/Bug/Display.html?id=101413 [2] https://github.com/KWARC/LaTeXML/blob/master/.travis.yml#L14 [3] http://pastebin.com/jZhcxZ1e
Download (untitled) / with headers
text/plain 297b
If you decide to maintain the incompatibility with older libraries, please ensure in the install code that the required library version is installed. You can do this in a vanilla Makefile.PL, Build.PL with Devel::CheckLib, or in Dist::Zilla-based distributions with Dist::Zilla::Plugin::CheckLib.
Download (untitled) / with headers
text/plain 546b
On Sun Jan 18 15:38:12 2015, d.ginev@jacobs-university.de wrote: Show quoted text
> Dear XML::LibXSLT maintainer(s), > > The resolution of the maxvars feature request [1], has broken > compatibility with older versions of libxslt. A notable case where this > is important is the Travis build system for GitHub repositories. By > default, Travis will try to use the newest XML::LibXSLT available to > cpanm, while lagging behind with the libxslt package. >
Thanks for the report. This should be fixed in XML-LibXSLT-1.94. Please test. Regards, -- Shlomi Fish


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.