Skip Menu |
 

This queue is for tickets about the Complete-Util CPAN distribution.

Report information
The Basics
Id: 101480
Status: resolved
Priority: 0/
Queue: Complete-Util

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.21
Fixed in: (no value)



Subject: Test failures since 2015-01-07
Download (untitled) / with headers
text/plain 255b
The test suite started to fail on 2015-01-07 and currently there are only fail reports for this module. See http://217.199.168.174/cgi-bin/cpantestersmatrix.pl?dist=Complete-Util;reports=1#sl=7,1 for a time-sorted overview of reports. Regards, Slaven
Download (untitled) / with headers
text/plain 426b
On Mon Jan 12 03:32:03 2015, SREZIC wrote: Show quoted text
> The test suite started to fail on 2015-01-07 and currently there are > only fail reports for this module. See http://217.199.168.174/cgi- > bin/cpantestersmatrix.pl?dist=Complete-Util;reports=1#sl=7,1 for a > time-sorted overview of reports. > > Regards, > Slaven
The failures were caused by a bug in Complete::Path 0.08 and Complete::Path 0.09+ have been released to fix it.
Download (untitled) / with headers
text/plain 980b
On 2015-01-12 05:34:19, PERLANCAR wrote: Show quoted text
> On Mon Jan 12 03:32:03 2015, SREZIC wrote:
> > The test suite started to fail on 2015-01-07 and currently there are > > only fail reports for this module. See http://217.199.168.174/cgi- > > bin/cpantestersmatrix.pl?dist=Complete-Util;reports=1#sl=7,1 for a > > time-sorted overview of reports. > > > > Regards, > > Slaven
> > The failures were caused by a bug in Complete::Path 0.08 and > Complete::Path 0.09+ have been released to fix it.
In this case, shouldn't Complete::Util make sure that the problematic Complete::Path version is upgraded? I.e. in your Makefile.PL: my $min_Complete_Path_VERSION = 0; if (eval { require Complete::Path; $Complete::Path::VERSION eq "0.08" }) { $min_Complete_Path_VERSION = '0.09'; } ... PREREQ_PM => { 'Complete::Path' => $min_Complete_Path_VERSION, ... } And making a new Complete-Util release has a side effect of getting a completely green matrix again ;-)
Subject: Re: [rt.cpan.org #101480] Test failures since 2015-01-07
Date: Tue, 13 Jan 2015 09:24:54 +0700
To: bug-Complete-Util [...] rt.cpan.org
From: Perl Ancar <perlancar [...] gmail.com>
Download (untitled) / with headers
text/plain 1.2k
Yeah, perhaps I should do that.. On Tue, Jan 13, 2015 at 5:43 AM, Slaven_Rezic via RT < bug-Complete-Util@rt.cpan.org> wrote: Show quoted text
> Queue: Complete-Util > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101480 > > > On 2015-01-12 05:34:19, PERLANCAR wrote:
> > On Mon Jan 12 03:32:03 2015, SREZIC wrote:
> > > The test suite started to fail on 2015-01-07 and currently there are > > > only fail reports for this module. See http://217.199.168.174/cgi- > > > bin/cpantestersmatrix.pl?dist=Complete-Util;reports=1#sl=7,1 for a > > > time-sorted overview of reports. > > > > > > Regards, > > > Slaven
> > > > The failures were caused by a bug in Complete::Path 0.08 and > > Complete::Path 0.09+ have been released to fix it.
> > In this case, shouldn't Complete::Util make sure that the problematic > Complete::Path version is upgraded? I.e. in your Makefile.PL: > > my $min_Complete_Path_VERSION = 0; > if (eval { require Complete::Path; $Complete::Path::VERSION eq "0.08" > }) { > $min_Complete_Path_VERSION = '0.09'; > } > > ... > > PREREQ_PM => { 'Complete::Path' => $min_Complete_Path_VERSION, ... } > > And making a new Complete-Util release has a side effect of getting a > completely green matrix again ;-) > >
Download (untitled) / with headers
text/plain 1.3k
Fixed & rereleased. On Mon Jan 12 21:25:05 2015, perlancar@gmail.com wrote: Show quoted text
> Yeah, perhaps I should do that.. > > On Tue, Jan 13, 2015 at 5:43 AM, Slaven_Rezic via RT < > bug-Complete-Util@rt.cpan.org> wrote: >
> > Queue: Complete-Util > > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=101480 > > > > > On 2015-01-12 05:34:19, PERLANCAR wrote:
> > > On Mon Jan 12 03:32:03 2015, SREZIC wrote:
> > > > The test suite started to fail on 2015-01-07 and currently there are > > > > only fail reports for this module. See http://217.199.168.174/cgi- > > > > bin/cpantestersmatrix.pl?dist=Complete-Util;reports=1#sl=7,1 for a > > > > time-sorted overview of reports. > > > > > > > > Regards, > > > > Slaven
> > > > > > The failures were caused by a bug in Complete::Path 0.08 and > > > Complete::Path 0.09+ have been released to fix it.
> > > > In this case, shouldn't Complete::Util make sure that the problematic > > Complete::Path version is upgraded? I.e. in your Makefile.PL: > > > > my $min_Complete_Path_VERSION = 0; > > if (eval { require Complete::Path; $Complete::Path::VERSION eq "0.08" > > }) { > > $min_Complete_Path_VERSION = '0.09'; > > } > > > > ... > > > > PREREQ_PM => { 'Complete::Path' => $min_Complete_Path_VERSION, ... } > > > > And making a new Complete-Util release has a side effect of getting a > > completely green matrix again ;-) > > > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.