Skip Menu |
 

This queue is for tickets about the Module-CPANTS-Analyse CPAN distribution.

Report information
The Basics
Id: 101418
Status: open
Priority: 0/
Queue: Module-CPANTS-Analyse

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: outdated Module::Install not being detected?
Download (untitled) / with headers
text/plain 283b
It appears that the bundled version of Module::Install isn't always detected. For example: https://metacpan.org/release/Parse-CPAN-Whois contains Module::Install 0.77, which I would have expected to trigger this metric: http://cpants.cpanauthors.org/kwalitee/no_broken_auto_install
Download (untitled) / with headers
text/plain 778b
On Fri Jan 09 09:37:05 2015, ETHER wrote: Show quoted text
> It appears that the bundled version of Module::Install isn't always > detected. For example: > > https://metacpan.org/release/Parse-CPAN-Whois > > contains Module::Install 0.77, which I would have expected to trigger > this metric: > http://cpants.cpanauthors.org/kwalitee/no_broken_auto_install
It's apparently a bug in documentation. Makefile.PL for Parse::CPAN::Whois doesn't have an "auto_install" statement, which is another key to "no_broken_auto_install" metric. Though M::I 0.77 is too old to use for now and it's about time to mark it "broken" (at QAH2015, or it may be a good target for PR Challenge?), "no_broken_auto_install" itself is working as expected. http://cpants.cpanauthors.org/dist/Parse-CPAN-Whois/metadata


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.