This queue is for tickets about the IO-Socket-IP CPAN distribution.

Report information
The Basics
Id:
101331
Status:
rejected
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
arocker [...] Vex.Net
Cc:
oleg [...] cpan.org
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: Test::Mojo install fails because dependency won't compile
Date: Mon, 5 Jan 2015 19:32:18 -0500
To: bug-IO-Socket-IP@rt.cpan.org
From: arocker@Vex.Net
Is this the right list, and have I supplied enough data? If not, what else would helP? I'm trying to install Test::Mojo, but it fails on a dependency: Building and testing Socket-2.016 ....... const-xs.inc: In function ‘XS_Socket_AUTOLOAD’: const-xs.inc:890: warning: format ‘%d’ expects type ‘int’, but argument 4 has type ‘line_t ’ const-xs.inc:895: warning: format ‘%d’ expects type ‘int’, but argument 4 has type ‘line_t ’ const-xs.inc:897: error: format not a string literal and no format arguments make: *** [Socket.o] Error 1 Environment: uname -a Linux localhost.localdomain 2.6.36.2-server-2mnb #1 SMP Wed Dec 22 20:21:23 UTC 2010 i686 i686 i386 GNU/Linux perl -v This is perl, v5.10.1 (*) built for i386-linux-thread-multi (with 1 registered patch, see perl -V for more detail)
On Mon Jan 05 19:35:57 2015, arocker@Vex.Net wrote:
Show quoted text
> Is this the right list, and have I supplied enough data? > If not, what else would helP? > > I'm trying to install Test::Mojo, but it fails on a dependency: > Building and testing Socket-2.016 > ....... > const-xs.inc: In function ‘XS_Socket_AUTOLOAD’: > const-xs.inc:890: warning: format ‘%d’ expects type ‘int’, but argument 4 > has type ‘line_t > ’ > const-xs.inc:895: warning: format ‘%d’ expects type ‘int’, but argument 4 > has type ‘line_t > ’ > const-xs.inc:897: error: format not a string literal and no format arguments > make: *** [Socket.o] Error 1 > > Environment: > > uname -a > Linux localhost.localdomain 2.6.36.2-server-2mnb #1 SMP Wed Dec 22 > 20:21:23 UTC 2010 i686 i686 i386 GNU/Linux > > perl -v > This is perl, v5.10.1 (*) built for i386-linux-thread-multi > (with 1 registered patch, see perl -V for more detail) > >
Can you provide output for: cc -v
Subject: Re: [rt.cpan.org #101331] Test::Mojo install fails because dependency won't compile
Date: Thu, 8 Jan 2015 10:09:44 -0500
To: bug-IO-Socket-IP@rt.cpan.org
From: arocker@Vex.Net
cc -v Using built-in specs. Target: i586-manbo-linux-gnu Configured with: ../configure --prefix=/usr --libexecdir=/usr/lib --with-slibdir=/lib --with-bugurl=https://qa.mandriva.com/ --mandir=/usr/share/man --infodir=/usr/share/info --enable-checking=release --enable-languages=c,c++,ada,fortran,objc,obj-c++,java --build=i586-manbo-linux-gnu --host=i586-manbo-linux-gnu --with-cpu=generic --with-system-zlib --enable-threads=posix --enable-shared --enable-objc-gc --enable-long-long --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --enable-java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-gtk-cairo --disable-libjava-multilib --enable-ssp --disable-libssp --disable-werror --with-ppl --with-cloog --with-python-dir=/lib/python2.6/site-packages Thread model: posix gcc version 4.4.3 (GCC)
On Thu Jan 08 10:13:44 2015, arocker@Vex.Net wrote:
Show quoted text
> cc -v > > Using built-in specs. > Target: i586-manbo-linux-gnu > Configured with: ../configure --prefix=/usr --libexecdir=/usr/lib > --with-slibdir=/lib --with-bugurl=https://qa.mandriva.com/ > --mandir=/usr/share/man --infodir=/usr/share/info > --enable-checking=release > --enable-languages=c,c++,ada,fortran,objc,obj-c++,java > --build=i586-manbo-linux-gnu --host=i586-manbo-linux-gnu > --with-cpu=generic --with-system-zlib --enable-threads=posix > --enable-shared --enable-objc-gc --enable-long-long --enable-__cxa_atexit > --disable-libunwind-exceptions --enable-clocale=gnu --enable-java-awt=gtk > --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre > --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-gtk-cairo > --disable-libjava-multilib --enable-ssp --disable-libssp --disable-werror > --with-ppl --with-cloog --with-python-dir=/lib/python2.6/site-packages > Thread model: posix > gcc version 4.4.3 (GCC) > > >
May be too old version of ExtUtils::Constant. perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' Should be 0.23
Subject: Re: [rt.cpan.org #101331] Test::Mojo install fails because dependency won't compile
Date: Fri, 9 Jan 2015 09:36:31 -0500
To: bug-IO-Socket-IP@rt.cpan.org
From: arocker@Vex.Net
Show quoted text
> May be too old version of ExtUtils::Constant. > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > Should be 0.23 >
That's what gets returned: perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' 0.23
On Fri Jan 09 09:36:47 2015, arocker@Vex.Net wrote:
Show quoted text
>
> > May be too old version of ExtUtils::Constant. > > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > > Should be 0.23 > >
> That's what gets returned: > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > 0.23 > > >
I can't reproduce it. Have you "perl-devel" package installed?
On Sat Jan 10 03:10:49 2015, OLEG wrote:
Show quoted text
> On Fri Jan 09 09:36:47 2015, arocker@Vex.Net wrote:
> >
> > > May be too old version of ExtUtils::Constant. > > > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > > > Should be 0.23 > > >
> > That's what gets returned: > > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > > 0.23 > > > > > >
> > I can't reproduce it. Have you "perl-devel" package installed?
Finally I can reproduce this with gcc 4.4.3. And this hack works for me: wget --no-check-certificate https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Socket-2.016.tar.gz tar xvzf Socket-2.016.tar.gz cd Socket-2.016 perl Makefile.PL sed -i 's/-Werror=format-security//' make make test make install
On Sat Jan 10 11:02:26 2015, OLEG wrote:
Show quoted text
> On Sat Jan 10 03:10:49 2015, OLEG wrote:
> > On Fri Jan 09 09:36:47 2015, arocker@Vex.Net wrote:
> > >
> > > > May be too old version of ExtUtils::Constant. > > > > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > > > > Should be 0.23 > > > >
> > > That's what gets returned: > > > perl -MExtUtils::Constant -E 'say ExtUtils::Constant->VERSION' > > > 0.23 > > > > > > > > >
> > > > I can't reproduce it. Have you "perl-devel" package installed?
> > Finally I can reproduce this with gcc 4.4.3. > And this hack works for me: > > wget --no-check-certificate > https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Socket-2.016.tar.gz > tar xvzf Socket-2.016.tar.gz > cd Socket-2.016 > perl Makefile.PL > sed -i 's/-Werror=format-security//' > make > make test > make install
should be sed -i 's/-Werror=format-security//' Makefile
Subject: Re: [rt.cpan.org #101331] Test::Mojo install fails because dependency won't compile
Date: Mon, 12 Jan 2015 15:58:52 -0500
To: bug-IO-Socket-IP@rt.cpan.org
From: arocker@Vex.Net
Show quoted text
> And this hack works for me: >
Appears to have worked for me, too. At least Test::Mojo installed without error messages. Thanks for the help.
Closing this as it seems to be a bug in the underlying ExtUtils::Constant, which OP reports as fixed anyway. -- Paul Evans
CC: oleg@cpan.org
Subject: Re: [rt.cpan.org #101331] Test::Mojo install fails because dependency won't compile
Date: Thu, 12 Mar 2015 16:19:42 -0400
To: bug-IO-Socket-IP@rt.cpan.org
From: arocker@Vex.Net
Show quoted text
> > Closing this as it seems to be a bug in the underlying ExtUtils::Constant, > which OP reports as fixed anyway. >
Thanks for the help. I'd classify it as "fixed" rather than "rejected"; what was broken now works, even if the fault lay outside the module.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.