Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the Catalyst-Plugin-Session-Store-Delegate CPAN distribution.

Report information
The Basics
Id: 100930
Status: rejected
Priority: 0/
Queue: Catalyst-Plugin-Session-Store-Delegate

People
Owner: Nobody in particular
Requestors: mojca [...] macports.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: use ok -> use_ok
Date: Mon, 15 Dec 2014 16:01:44 +0100
To: bug-Catalyst-Plugin-Session-Store-Delegate [...] rt.cpan.org
From: Mojca Miklavec <mojca [...] macports.org>
Download (untitled) / with headers
text/plain 199b
Hello, There's probably an underscore missing in t/00_use.t, else Perl tests fail, trying to search for "ok.pm". Attempt of a patch attached (but maybe it's even better to use parenthesis). Mojca

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 440b
On 2014-12-15 07:02:00, mojca@macports.org wrote: Show quoted text
> Hello, > > There's probably an underscore missing in t/00_use.t, else Perl tests > fail, trying to search for "ok.pm".
ok.pm is a valid module. The code is correct. It's also correctly listed in the prereq specification: https://metacpan.org/source/BOBTFISH/Catalyst-Plugin-Session-Store-Delegate-0.06/META.yml#L8 How did you install the module? You need to satisfy all prereqs first.
Subject: Re: [rt.cpan.org #100930] use ok -> use_ok
Date: Mon, 15 Dec 2014 18:44:57 +0100
To: bug-Catalyst-Plugin-Session-Store-Delegate [...] rt.cpan.org
From: Mojca Miklavec <mojca [...] macports.org>
On Mon, Dec 15, 2014 at 6:25 PM, Karen Etheridge via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=100930 > > > On 2014-12-15 07:02:00, mojca@macports.org wrote:
>> Hello, >> >> There's probably an underscore missing in t/00_use.t, else Perl tests >> fail, trying to search for "ok.pm".
> > ok.pm is a valid module. The code is correct. > > It's also correctly listed in the prereq specification: https://metacpan.org/source/BOBTFISH/Catalyst-Plugin-Session-Store-Delegate-0.06/META.yml#L8 > > How did you install the module? You need to satisfy all prereqs first.
Thank you very much for the explanation. Initially I wasn't aware that I was only missing a dependency. When I was updating packages in a package manager I extracted the list of dependencies with a tool that is apparently buggy, so the bug needs to be fixed there: http://trac.macports.org/ticket/46247 I'm very sorry for the false alarm and thank you for clarification. At least I know now whom to blame next ;). You may close the bug report as invalid. Thank you, Mojca


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.