Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 100555
Status: resolved
Priority: 0/
Queue: GD

People
Owner: Nobody in particular
Requestors: COSMICNET [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Not working under FastCGI
Download (untitled) / with headers
text/plain 610b
Hi, I see in version 2.55 of GD you removed the FastCGI instructions from the Readme file. I have found that my application will not run under FastCGI with GD included. I found the Readme from versions pre 2.55 and recompiled with FCGI enabled. I had to grab the header files: http://www.fastcgi.com/devkit/include/fcgi_stdio.h http://www.fastcgi.com/devkit/include/fcgiapp.h For it to build. But unfortunately, after a successful build my program is still not able to run under FastCGI if it includes GD. The GD module appears otherwise functional. Please let me know how I may assist in fixing this issue.
Download (untitled) / with headers
text/plain 326b
I'm seeing the bug on Strawberry Perl 5.20.1 with GD 2.56, WAMP 2 with mod_fcgid. For sanity I just tested the same on CentOS 6.5 with Perl 5.10.1 Apache 2 mod_fcgid and it worked fine. At this time I'm not sure where this issue is (Perl ver, Strawberry, WAMP mod_fcgid). I'll let you know if I find more in further testing.
Download (untitled) / with headers
text/plain 117b
I've added a --fcgi option which uses -DFCGI, #include <fcgi_stdio.h> and -lfcgi tested ok for me. -- Reini Urban


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.