Skip Menu |
 

This queue is for tickets about the PAR-Packer CPAN distribution.

Report information
The Basics
Id: 100090
Status: rejected
Priority: 0/
Queue: PAR-Packer

People
Owner: Nobody in particular
Requestors: eiii [...] pacbell.net
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: PAR-Packer-1.023 Execution failure in CentOS 6.2x64
Date: Wed, 5 Nov 2014 15:42:39 -0800
To: <bug-PAR [...] rt.cpan.org>
From: "Lance Gropper" <eiii [...] pacbell.net>
Download (untitled) / with headers
text/plain 798b
[root@QOS PAR-Packer-1.023]# pp Can't locate Module/Metadata.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/local/share/perl5/Module/ScanDeps.pm line 29. BEGIN failed--compilation aborted at /usr/local/share/perl5/Module/ScanDeps.pm line 29. Compilation failed in require at /usr/local/share/perl5/PAR/Packer.pm line 34. BEGIN failed--compilation aborted at /usr/local/share/perl5/PAR/Packer.pm line 34. Compilation failed in require at /usr/local/share/perl5/pp.pm line 5. BEGIN failed--compilation aborted at /usr/local/share/perl5/pp.pm line 5. Compilation failed in require at /usr/local/bin/pp line 5. BEGIN failed--compilation aborted at /usr/local/bin/pp line 5.
Download (untitled) / with headers
text/plain 703b
Am 2014-11-05 18:42:45, eiii@pacbell.net schrieb: Show quoted text
> [root@QOS PAR-Packer-1.023]# pp > Can't locate Module/Metadata.pm in @INC (@INC contains: > /usr/local/lib64/perl5 /usr/local/share/perl5 > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl > /usr/lib64/perl5 /usr/share/perl5 .) at > /usr/local/share/perl5/Module/ScanDeps.pm line 29. > BEGIN failed--compilation aborted at > /usr/local/share/perl5/Module/ScanDeps.pm line 29.
Module::ScanDeps isn't installed correctly - its Makefile.PL clearly states: requires 'Module::Metadata' => '0'; BTW, you obviously didn't run "make test" when installing PAR::Packer, otherwise you would have caught this earlier. Cheers, Roderich
Subject: Re: [rt.cpan.org #100090] PAR-Packer-1.023 Execution failure in CentOS 6.2x64
Date: Thu, 6 Nov 2014 09:28:14 -0800
To: <bug-PAR-Packer [...] rt.cpan.org>
From: "Lance Gropper" <eiii [...] pacbell.net>
Download (untitled) / with headers
text/plain 1.5k
At some point, you should try to be a little more helpful. You can see there is a problem with ScanDeps without running make test. I was requesting help - not requesting a description of what I did wrong. The version of ScanDeps which comes with CentOS 6.2x64 doesn't work (0.90), the latest one via yum doesn't work (0.92), the latest one on the internet (1.17) causes the problem you see below. None of them install with any problems. PAR-Packer-1.023 seems to only work with a specific version range (which isn't documented anywhere that I could find). The one I found which worked was version 0.97. Show quoted text
-----Original Message----- From: Roderich Schupp via RT Sent: Wednesday, November 5, 2014 11:59 PM To: eiii@pacbell.net Subject: [rt.cpan.org #100090] PAR-Packer-1.023 Execution failure in CentOS 6.2x64 <URL: https://rt.cpan.org/Ticket/Display.html?id=100090 > Am 2014-11-05 18:42:45, eiii@pacbell.net schrieb:
> [root@QOS PAR-Packer-1.023]# pp > Can't locate Module/Metadata.pm in @INC (@INC contains: > /usr/local/lib64/perl5 /usr/local/share/perl5 > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl > /usr/lib64/perl5 /usr/share/perl5 .) at > /usr/local/share/perl5/Module/ScanDeps.pm line 29. > BEGIN failed--compilation aborted at > /usr/local/share/perl5/Module/ScanDeps.pm line 29.
Module::ScanDeps isn't installed correctly - its Makefile.PL clearly states: requires 'Module::Metadata' => '0'; BTW, you obviously didn't run "make test" when installing PAR::Packer, otherwise you would have caught this earlier. Cheers, Roderich
Download (untitled) / with headers
text/plain 1.1k
On 2014-11-06 12:28:21, eiii@pacbell.net wrote: Show quoted text
> At some point, you should try to be a little more helpful. You can see > there > is a problem with ScanDeps without running make test.
No, YOU are not helpful here. You should NOT install Perl modules without running "make test". Also you're generally on your own if "make test" fails and you install the modules nonetheless. Your're welcome to submit a bug report in this case, though. Show quoted text
> PAR-Packer-1.023 seems to only work with a specific version range > (which isn't documented anywhere that I could find).
Nonsense, PAR::Packer states (Makefile.PL) requires 'Module::ScanDeps' => '1.17'; If you did the whole "download and unpack tarball, perl Makefile.PL, make, make test, make install" dance by hand, then running "perl Makefile.PL" would have shown that you are missing dependencies. If you did ignore that, then at least "make test" would have failed. BTW, I heavily recommend to use a program like "cpan" (comes with Perl core) or "cpanm" to install Perl modules. Both would have inferred the above dependency of PAR::Packer and installed Modules::ScanDeps BEFORE working on PAR::Packer. Cheers, Roderich
Subject: Re: [rt.cpan.org #100090] PAR-Packer-1.023 Execution failure in CentOS 6.2x64
Date: Fri, 7 Nov 2014 06:23:54 -0800
To: <bug-PAR-Packer [...] rt.cpan.org>
From: "Lance Gropper" <eiii [...] pacbell.net>
Download (untitled) / with headers
text/plain 2.3k
Hello Roderich: You are making no sense: The latest ScanDeps is what caused the problem (so apparently it doesn't work with PAR Packer 1.023). The one I installed doesn't even meet the requirement you show below, but it worked. I posted this thread requesting help and all you give me is grief and bullshit. When I reported the problem, I knew there was a problem with ScanDeps, but there was no problem installing ScanDeps (also there is no rule for make test on it), and the error only appeared when doing a make test or executing pp. I was requesting help with the problem, which I didn't get until you recommended cpan below. All I got back is - ScanDeps was installed incorrectly. How do you install it incorrectly? It is just a make and make install just like PAR-Packer. I wasn't missing any dependencies - make test or not. It is an incompatibility between PAR-Packer and the latest ScanDeps. Lance Show quoted text
-----Original Message----- From: Roderich Schupp via RT Sent: Friday, November 7, 2014 12:49 AM To: eiii@pacbell.net Subject: [rt.cpan.org #100090] PAR-Packer-1.023 Execution failure in CentOS 6.2x64 <URL: https://rt.cpan.org/Ticket/Display.html?id=100090 > On 2014-11-06 12:28:21, eiii@pacbell.net wrote:
> At some point, you should try to be a little more helpful. You can see > there > is a problem with ScanDeps without running make test.
No, YOU are not helpful here. You should NOT install Perl modules without running "make test". Also you're generally on your own if "make test" fails and you install the modules nonetheless. Your're welcome to submit a bug report in this case, though.
> PAR-Packer-1.023 seems to only work with a specific version range > (which isn't documented anywhere that I could find).
Nonsense, PAR::Packer states (Makefile.PL) requires 'Module::ScanDeps' => '1.17'; If you did the whole "download and unpack tarball, perl Makefile.PL, make, make test, make install" dance by hand, then running "perl Makefile.PL" would have shown that you are missing dependencies. If you did ignore that, then at least "make test" would have failed. BTW, I heavily recommend to use a program like "cpan" (comes with Perl core) or "cpanm" to install Perl modules. Both would have inferred the above dependency of PAR::Packer and installed Modules::ScanDeps BEFORE working on PAR::Packer. Cheers, Roderich


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.