Skip Menu |
 

This queue is for tickets about the Dist-Zilla-Plugin-Test-Kwalitee CPAN distribution.

Report information
The Basics
Id: 98268
Status: resolved
Priority: 0/
Queue: Dist-Zilla-Plugin-Test-Kwalitee

People
Owner: ether [...] cpan.org
Requestors: jonasbn [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.08
Fixed in: 2.09



Subject: Explicit requirement for Test::Kwalitee version?
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Message-ID: <rt-4.0.18-15177-1408743046-623.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 516
Download (untitled) / with headers
text/plain 516b
I got this error when testing one of my distribution using Travis CI. [20:38:57] t/release-kwalitee.t ...... Test::Kwalitee version 1.21 required--this is only version 1.18 at t/release-kwalitee.t line 13. BEGIN failed--compilation aborted at t/release-kwalitee.t line 13. [20:38:57] t/release-kwalitee.t ...... Dubious, test returned 255 (wstat 65280, 0xff00) No subtests run I am unsure the Test::Kwalitee version requirement is specified implicitly in the Dist-Zilla-Plugin-Test-Kwalitee distribution? jonasbn
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-15177-1408743046-623.0-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-4.0.18-15177-1408743046-623.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-888-1408746995-1954.98268-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 1244
Download (untitled) / with headers
text/plain 1.2k
On 2014-08-22 14:30:46, JONASBN wrote: Show quoted text
> I got this error when testing one of my distribution using Travis CI. > > [20:38:57] t/release-kwalitee.t ...... Test::Kwalitee version 1.21 > required--this is only version 1.18 at t/release-kwalitee.t line 13. > BEGIN failed--compilation aborted at t/release-kwalitee.t line 13. > [20:38:57] t/release-kwalitee.t ...... Dubious, test returned 255 > (wstat 65280, 0xff00) > No subtests run > > I am unsure the Test::Kwalitee version requirement is specified > implicitly in the Dist-Zilla-Plugin-Test-Kwalitee distribution? > > jonasbn
It's injected into your distribution's 'develop' prerequisites. Your .travis.yml should be doing something like: 'dzil authordeps --missing | cpanm; dzil listdeps --author --missing | cpanm' to install all the necessary prerequisites. You also might find this of use: https://github.com/haarg/perl-travis-helper -- it was recently added to the Moose repository, which fixed a lot of errors we get with travis occasionally: https://github.com/moose/Moose/commit/bbdd5ec2314a35bbe15fe8cd13fd01a5c6ff42db However, since this plugin does use Test::Kwalitee right in its own installation tests, I should really declare a test prerequisite - I'll fix that tonight!
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-888-1408746995-1954.98268-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-4.0.18-15177-1408743046-623.0-0-0 [...] rt.cpan.org> <rt-4.0.18-888-1408746995-1954.98268-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-25604-1408747095-1608.98268-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 384
Download (untitled) / with headers
text/plain 384b
On 2014-08-22 15:36:35, ETHER wrote: Show quoted text
> However, since this plugin does use Test::Kwalitee right in its own > installation tests, I should really declare a test prerequisite - I'll > fix that tonight!
Heh, I forgot that I took those tests out because I kept getting failure reports with the way that I was using Capture::Tiny... I'll add back in a safer, more minimal test instead.
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-15177-1408743046-623.0-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-4.0.18-15177-1408743046-623.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-6648-1408783549-167.98268-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 48
There is an explicit prereq in the 2.09 release.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.