Skip Menu |
 

This queue is for tickets about the Module-CPANTS-Analyse CPAN distribution.

Report information
The Basics
Id: 91550
Status: new
Priority: 0/
Queue: Module-CPANTS-Analyse

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: new kwalitee metric: missing configure_requires metadata
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Message-ID: <rt-4.0.18-18752-1387590599-1602.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 349
Download (untitled) / with headers
text/plain 349b
e.g. see https://github.com/miyagawa/cpanminus/issues/322 Any distribution with a Build.PL should have a proper configure_requires entry in META.* that indicates what is necessary to use the Build.PL file (Module::Build or Module::Build::Tiny). For that matter, even dists with Makefile.PL should be specifying a dependency on ExtUtils::MakeMaker.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.