Skip Menu |
 

This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id: 86398
Status: open
Priority: 0/
Queue: XML-LibXSLT

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.80
Fixed in: (no value)

Attachments
XML-LibXSLT-1.95-Do-not-require-the-same-build-and-run-time-version-o.patch



Subject: Overeager basic.t reports error where nothing is broken
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Message-ID: <rt-4.0.13-27363-1372147793-451.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 632
Download (untitled) / with headers
text/plain 632b
As per subject. Sample fail report: http://www.cpantesters.org/cpan/report/ced6de70-db7d-11e2-8100-f24e697f9654 The test suite shows that no harm is done but basic.t reports that the version number of the libxml2 is not the same anymore as the version number was when XML::LibXML was built. If no other tests fail, this test is nonsense because an apparently compatible shared library is in place. Please remove this test or amend it to become a warning that says something like "Probably harmless observation: version numbers not matching" or some such. Or only notice the mismatch when actually something is broken. Thank you,
MIME-Version: 1.0
In-Reply-To: <rt-4.0.13-27363-1372147793-451.0-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-4.0.13-27363-1372147793-451.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-14163-1393342983-87.86398-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 219
Download (untitled) / with headers
text/plain 219b
I also get this error when building XML::LibXSLT with the original XML::LibXML shipped with Ubuntu 13.10. I think the proper fix would be to check that the runtime version is greater or equal than the compiled verison.
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-14163-1393342983-87.86398-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
X-RT-Interface: API
References: <rt-4.0.13-27363-1372147793-451.0-0-0 [...] rt.cpan.org> <rt-4.0.18-14163-1393342983-87.86398-0-0 [...] rt.cpan.org>
Content-Type: multipart/mixed; boundary="----------=_1483455837-15953-9"
Message-ID: <rt-4.0.18-15953-1483455837-320.0-0-0 [...] rt.cpan.org>
Message-ID: <rt-4.0.18-15953-1483455837-659.86398-0-0 [...] rt.cpan.org>
X-RT-Original-Encoding: utf-8
From: ppisar [...] redhat.com
Content-Length: 0
Content-Disposition: inline
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 199
Download (untitled) / with headers
text/plain 199b
Dne Út 25.úno.2014 10:43:03, NWELLNHOF napsal(a): Show quoted text
> I think the proper fix would be to check that the runtime version is > greater or equal than the compiled verison.
Attached patch implements it.
MIME-Version: 1.0
Subject: XML-LibXSLT-1.95-Do-not-require-the-same-build-and-run-time-version-o.patch
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Type: application/octet-stream; name="XML-LibXSLT-1.95-Do-not-require-the-same-build-and-run-time-version-o.patch"
Content-Disposition: inline; filename="XML-LibXSLT-1.95-Do-not-require-the-same-build-and-run-time-version-o.patch"
Content-Transfer-Encoding: base64
Content-Length: 1150
From 9a573cdc37e592880a4c96e98a2f8ea6a55bd63b Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com> Date: Tue, 3 Jan 2017 15:59:16 +0100 Subject: [PATCH] Do not require the same build and run time version of libxml2 MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit CPAN RT#86398 Signed-off-by: Petr Písař <ppisar@redhat.com> --- t/01basic.t | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/t/01basic.t b/t/01basic.t index b525847..d48c463 100644 --- a/t/01basic.t +++ b/t/01basic.t @@ -19,7 +19,7 @@ ok($p, ' TODO : Add test name'); is(XML::LibXSLT::LIBXSLT_VERSION(), XML::LibXSLT::LIBXSLT_RUNTIME_VERSION(), 'LIBXSLT_VERSION is the same as the runtime version.'); # TEST -is(XML::LibXML::LIBXML_VERSION(), XML::LibXML::LIBXML_RUNTIME_VERSION(), 'LibXML version is the same as its run time version.'); +ok(XML::LibXML::LIBXML_VERSION() <= XML::LibXML::LIBXML_RUNTIME_VERSION(), 'LibXML build time version is not newer than its run time version.'); warn "\n\nCompiled against: ", "libxslt ",XML::LibXSLT::LIBXSLT_VERSION(), -- 2.7.4


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.