Skip Menu |
 

This queue is for tickets about the URI CPAN distribution.

Report information
The Basics
Id: 77494
Status: resolved
Priority: 0/
Queue: URI

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.60
Fixed in: 1.61



Subject: Unescaped left brace in regex is deprecated
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
X-RT-Original-Encoding: utf-8
Content-Type: multipart/mixed; boundary="----------=_1338189631-4152-3"
Content-Length: 0
Content-Type: text/plain; charset="UTF-8"
Content-Disposition: inline
Content-Transfer-Encoding: binary
Content-Length: 205
Download (untitled) / with headers
text/plain 205b
The new deprecation warning in bleadperl hits in the t/escape.t test. The attached patch silences it. Canonical ticket for the change: https://rt.perl.org/rt3//Public/Bug/Display.html?id=113094 Regards,
Subject: URI-1.60-ANDK-01.diff
MIME-Version: 1.0
Content-Type: text/x-diff; name="URI-1.60-ANDK-01.diff"
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline; filename="URI-1.60-ANDK-01.diff"
Content-Transfer-Encoding: binary
Content-Length: 427
--- t/escape.t~ 2012-02-11 15:48:54.000000000 +0100 +++ t/escape.t 2012-05-28 09:12:26.817866976 +0200 @@ -34,6 +34,6 @@ skip "Perl 5.8.0 or higher required", 3 if $] < 5.008; ok !eval { print uri_escape("abc" . chr(300)); 1 }; -like $@, qr/^Can\'t escape \\x{012C}, try uri_escape_utf8\(\) instead/; +like $@, qr/^Can\'t escape \\x\{012C}, try uri_escape_utf8\(\) instead/; is uri_escape_utf8(chr(0xFFF)), "%E0%BF%BF";
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-21261-1404498136-1487.77494-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 286
Download (untitled) / with headers
text/plain 286b
Fixed in 1.61. Oddly, the warning only manifests itself with 5.21.1 -- it is not present in 5.20.0. And yet, the relevant blead commit (http://perl5.git.perl.org/perl.git/commit/2a53d3314d380af5ab5283758219417c6dfa36e9) first appeared in the 5.17.0 release! was it reverted, perhaps?
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-13656-1404542091-1508.77494-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 250
Download (untitled) / with headers
text/plain 250b
5.16.3 did not warn. Early 5.17.0 started with "left brace" warning, around 5.17.8 this went away but gave birth to "useless use of '\'" warning. Reintroduced recently in v5.21.0-382-g412f55b, see https://rt.perl.org/rt3/Ticket/Display.html?id=122146


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.