Skip Menu |
 

This queue is for tickets about the HTTP-Proxy CPAN distribution.

Report information
The Basics
Id: 71771
Status: resolved
Priority: 0/
Queue: HTTP-Proxy

People
Owner: Nobody in particular
Requestors: enquiries [...] mikeraynham.co.uk
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Installation fails if HTML::Parser not already installed
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
X-RT-Original-Encoding: utf-8
Content-Type: multipart/mixed; boundary="----------=_1319014778-2599-126"
Content-Length: 0
Content-Type: text/plain; charset="UTF-8"
Content-Disposition: inline
Content-Transfer-Encoding: binary
Content-Length: 1466
Download (untitled) / with headers
text/plain 1.4k
Here's an extract from the build log: t/64tags.t .......... ok Can't locate loadable object for module HTML::Parser in @INC (@INC contains: /home/mike/.cpanm/work/1319014037.16471/HTTP-Proxy-0.25/blib/lib /home/mike/.cpanm/work/1319014037.16471/HTTP-Proxy-0.25/blib/arch /home/mike/.cpanm/work/1319014037.16471 /secure/extlib/lib/perl5/x86_64-linux- thread-multi /secure/extlib/lib/perl5/x86_64-linux-thread-multi /secure/extlib/lib/perl5 /secure/extlib/lib/perl5/x86_64-linux-thread-multi /secure/extlib/lib/perl5/x86_64-linux- thread-multi /secure/extlib/lib/perl5 /secure/extlib/lib/perl5/x86_64-linux-thread-multi /secure/extlib/lib/perl5/x86_64-linux-thread-multi /secure/extlib/lib/perl5 /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64- linux-thread-multi /usr/lib/perl5/5.8.8 .) at t/66htmlparser.t line 5 Compilation failed in require at t/66htmlparser.t line 5. BEGIN failed--compilation aborted at t/66htmlparser.t line 5. # Looks like your test exited with 2 before it could output anything. t/66htmlparser.t .... Dubious, test returned 2 (wstat 512, 0x200) Failed 5/5 subtests t/67complete.t ...... ok After manually installing HTML::Parser, the HTTP::Proxy installation succeeded. I have attached an updated Makefile.PL.
Subject: Makefile.PL
MIME-Version: 1.0
Content-Type: text/x-perl-script; name="Makefile.PL"
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline; filename="Makefile.PL"
Content-Transfer-Encoding: binary
Content-Length: 398
Download Makefile.PL
text/x-perl 398b
use ExtUtils::MakeMaker; WriteMakefile( NAME => 'HTTP::Proxy', VERSION_FROM => 'lib/HTTP/Proxy.pm', PREREQ_PM => { 'Test::More' => 0, 'HTTP::Daemon' => 1.25, 'LWP::UserAgent' => 2, 'HTML::Parser' => 3.69, }, PL_FILES => {}, ABSTRACT_FROM => 'lib/HTTP/Proxy.pm', AUTHOR => 'Philippe "BooK" Bruhat <book@cpan.org>', );


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.