Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Test-WWW-Mechanize CPAN distribution.

Report information
The Basics
Id: 68461
Status: resolved
Priority: 0/
Queue: Test-WWW-Mechanize

People
Owner: Nobody in particular
Requestors: maik.hentsche [...] amd.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



X-Forefront-Antispam-Report: CIP:163.181.249.109;KIP:(null);UIP:(null);IPVD:NLI;H:ausb3twp02.amd.com;RD:none;EFVD:NLI
From maik.hentsche [...] amd.com Wed May 25 08: 34:27 2011
MIME-Version: 1.0
X-Spam-Status: No, score=-6.9 tagged_above=-99.9 required=10 tests=[AWL=0.000, BAYES_00=-1.9, RCVD_IN_DNSWL_HI=-5] autolearn=ham
X-Mailer: Claws Mail 3.7.2 (GTK+ 2.18.3; x86_64-pc-linux-gnu)
X-Bigfish: VPS1(zzzz1202hzzz32i668h839h34h64h)
X-Spam-Flag: NO
X-Virus-Checked: Checked by ClamAV on 16.mx.develooper.com
Content-Type: multipart/signed; micalg=PGP-SHA1; boundary="Sig_/slusurDCSN0/2ZIWUry7._/"; protocol="application/pgp-signature"
Message-ID: <20110525143409.5cac3fe0 [...] siegfried.osrc.amd.com>
X-Virus-Scanned: Debian amavisd-new at bestpractical.com
X-Spam-Score: -6.9
Received: from localhost (localhost [127.0.0.1]) by hipster.bestpractical.com (Postfix) with ESMTP id 987CE241A84 for <cpan-bug+Test-WWW-Mechanize [...] hipster.bestpractical.com>; Wed, 25 May 2011 08:34:27 -0400 (EDT)
Received: from hipster.bestpractical.com ([127.0.0.1]) by localhost (hipster.bestpractical.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id B4nHB5HHzHKB for <cpan-bug+Test-WWW-Mechanize [...] hipster.bestpractical.com>; Wed, 25 May 2011 08:34:26 -0400 (EDT)
Received: from la.mx.develooper.com (x1.develooper.com [207.171.7.70]) by hipster.bestpractical.com (Postfix) with SMTP id 89409241A2A for <bug-Test-WWW-Mechanize [...] rt.cpan.org>; Wed, 25 May 2011 08:34:25 -0400 (EDT)
Received: (qmail 28409 invoked by uid 103); 25 May 2011 12:34:24 -0000
Received: from x16.dev (10.0.100.26) by x1.dev with QMQP; 25 May 2011 12:34:24 -0000
Received: from am1ehsobe003.messaging.microsoft.com (HELO AM1EHSOBE003.bigfish.com) (213.199.154.206) by 16.mx.develooper.com (qpsmtpd/0.80/v0.80-19-gf52d165) with ESMTP; Wed, 25 May 2011 05:34:22 -0700
Received: from mail45-am1-R.bigfish.com (10.3.201.241) by AM1EHSOBE003.bigfish.com (10.3.204.23) with Microsoft SMTP Server id 14.1.225.22; Wed, 25 May 2011 12:34:18 +0000
Received: from mail45-am1 (localhost.localdomain [127.0.0.1]) by mail45-am1-R.bigfish.com (Postfix) with ESMTP id BBF66D180ED for <bug-Test-WWW-Mechanize [...] rt.cpan.org>; Wed, 25 May 2011 12:34:18 +0000 (UTC)
Received: from mail45-am1 (localhost.localdomain [127.0.0.1]) by mail45-am1 (MessageSwitch) id 1306326858451464_18495; Wed, 25 May 2011 12:34:18 +0000 (UTC)
Received: from AM1EHSMHS017.bigfish.com (unknown [10.3.201.250]) by mail45-am1.bigfish.com (Postfix) with ESMTP id 676D1176004F for <bug-Test-WWW-Mechanize [...] rt.cpan.org>; Wed, 25 May 2011 12:34:18 +0000 (UTC)
Received: from ausb3twp02.amd.com (163.181.249.109) by AM1EHSMHS017.bigfish.com (10.3.207.155) with Microsoft SMTP Server id 14.1.225.22; Wed, 25 May 2011 12:34:17 +0000
Received: from sausexedgep02.amd.com (sausexedgep02-ext.amd.com [163.181.249.73]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by ausb3twp02.amd.com (Axway MailGate 3.8.1) with ESMTP id 2B12BC8458 for <bug-Test-WWW-Mechanize [...] rt.cpan.org>; Wed, 25 May 2011 07:34:13 -0500 (CDT)
Received: from sausexhtp02.amd.com (163.181.3.152) by sausexedgep02.amd.com (163.181.36.59) with Microsoft SMTP Server (TLS) id 8.3.106.1; Wed, 25 May 2011 07:34:26 -0500
Received: from storexhtp02.amd.com (172.24.4.4) by sausexhtp02.amd.com (163.181.3.152) with Microsoft SMTP Server (TLS) id 8.3.83.0; Wed, 25 May 2011 07:34:14 -0500
Received: from gwo.osrc.amd.com (165.204.16.204) by storexhtp02.amd.com (172.24.4.4) with Microsoft SMTP Server id 8.3.83.0; Wed, 25 May 2011 08:34:13 -0400
Received: from siegfried.osrc.amd.com (siegfried.osrc.amd.com [165.204.15.37]) by gwo.osrc.amd.com (Postfix) with ESMTP id 9169549C1FB for <bug-Test-WWW-Mechanize [...] rt.cpan.org>; Wed, 25 May 2011 13:34:12 +0100 (BST)
Delivered-To: cpan-bug+Test-WWW-Mechanize [...] hipster.bestpractical.com
Subject: Test "Fails to get nonexistent URI and reports failure"
Return-Path: <maik.hentsche [...] amd.com>
X-RT-Mail-Extension: test-www-mechanize
X-Original-To: cpan-bug+Test-WWW-Mechanize [...] hipster.bestpractical.com
X-Spam-Check-BY: 16.mx.develooper.com
Date: Wed, 25 May 2011 14:34:09 +0200
X-Originatororg: amd.com
X-Spam-Level:
X-M-MSG:
To: <bug-Test-WWW-Mechanize [...] rt.cpan.org>
X-WSS-ID: 0LLR491-02-57S-02
X-Spamscore: 1
X-Spam-TCS-SCL: 3:0
From: Maik Hentsche <maik.hentsche [...] amd.com>
Content-Length: 0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
X-RT-Original-Encoding: utf-8
Content-Length: 4229
Download (untitled) / with headers
text/plain 4.1k
Hi! Installing Test-WWW-Mechanize fails during make test. I assume that the error message changed and thus does no longer match the regexp in the test. My perl version is v5.12.1 built for x86_64-linux. I get the following output: t/back_ok.t ............. 9/11 # Failed test 'Fails to get nonexistent URI and reports failure' # at t/back_ok.t line 59. # STDERR is: # # Failed test 'Try to get bad URL' # # at t/back_ok.t line 58. # # 500 # # Can't connect to wango.nonexistent.xx-only-testing:80 (Bad hostname) # # not: # /#\s+Failed\ test.*?\n?.*?at\ t\/back_ok\.t line 58.*\n?/ # # # 500 # # # Can't connect to wango.nonexistent.xx-only-testing:80 (Bad hostname 'wango.nonexistent.xx-only-testing') # # as expected t/back_ok.t ............. Failed 1/11 subtests t/click_ok.t ............ ok t/content_contains.t .... ok t/content_lacks.t ....... 2/5 # Failed test 'Handles not finding it' # at t/content_lacks.t line 40. # STDERR is: # # Failed test 'Shouldn't say it's a test page' # # at t/content_lacks.t line 39. # # searched: "<html>\x{0a} <head>\x{0a} <title>Test Page</title>"... # # and found: "Test Page" # # at position: 33 (line 3 column 16) # # not: # /#\s+Failed\ test.*?\n?.*?at\ t\/content_lacks\.t line 39.*\n?/ # # # searched: "<html>\x{0a} <head>\x{0a} <title>Test Page</title>"... # # # and found: "Test Page" # # # at position: 33 # # as expected t/content_lacks.t ....... Failed 1/5 subtests t/follow_link_ok.t ...... ok t/followable_links.t .... ok t/get_ok-parms.t ........ ok t/get_ok.t .............. 3/11 # Failed test 'Fails to get nonexistent URI and reports failure' # at t/get_ok.t line 60. # STDERR is: # # Failed test 'Try to get bad URL' # # at t/get_ok.t line 59. # # 500 # # Can't connect to wango.nonexistent.xx-only-testing:80 (Bad hostname) # # not: # /#\s+Failed\ test.*?\n?.*?at\ t\/get_ok\.t line 59.*\n?/ # # # 500 # # # Can't connect to wango.nonexistent.xx-only-testing:80 (Bad hostname 'wango.nonexistent.xx-only-testing') # # as expected t/get_ok.t .............. Failed 1/11 subtests t/has_tag.t ............. ok t/head_ok-parms.t ....... ok t/head_ok.t ............. 9/11 # Failed test 'Fails to HEAD nonexistent URI and reports failure' # at t/head_ok.t line 59. # STDERR is: # # Failed test 'Try to HEAD bad URL' # # at t/head_ok.t line 58. # # 500 # # Can't connect to wango.nonexistent.xx-only-testing:80 (Bad hostname) # # not: # /#\s+Failed\ test.*?\n?.*?at\ t\/head_ok\.t line 58.*\n?/ # # # 500 # # # Can't connect to wango.nonexistent.xx-only-testing:80 (Bad hostname 'wango.nonexistent.xx-only-testing') # # as expected t/head_ok.t ............. Failed 1/11 subtests t/html_lint_ok.t ........ skipped: HTML::Lint is not installed, cannot test html_lint_ok t/link_content.t ........ ok t/link_status.t ......... ok t/links_ok.t ............ ok t/new.t ................. ok t/page_links_content.t .. ok t/page_links_ok.t ....... ok t/pod-coverage.t ........ ok t/pod.t ................. ok t/put_ok.t .............. ok t/stuff_inputs.t ........ ok t/submit_form_ok.t ...... ok t/text_contains.t ....... ok Test Summary Report ------------------- t/back_ok.t (Wstat: 0 Tests: 11 Failed: 1) Failed test: 9 t/content_lacks.t (Wstat: 0 Tests: 5 Failed: 1) Failed test: 5 t/get_ok.t (Wstat: 0 Tests: 11 Failed: 1) Failed test: 9 t/head_ok.t (Wstat: 0 Tests: 11 Failed: 1) Failed test: 9 Files=26, Tests=203, 28 wallclock secs ( 0.15 usr 0.08 sys + 4.98 cusr 1.26 csys = 6.47 CPU) Result: FAIL Failed 4/26 test programs. 4/203 subtests failed. make: *** [test_dynamic] Fehler 255 PETDANCE/Test-WWW-Mechanize-1.30.tar.gz make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports PETDANCE/Test-WWW-Mechanize-1.30.tar.gz Running make install make test had returned bad status, won't install without force -- Advanced Micro Devices GmbH Sitz: Dornach, Gemeinde Aschheim, Landkreis München Registergericht München, HRB Nr. 43632 - WEEE Registrierungsnummer 129 19551 Geschäftsführer: Alberto Bozzo, Andrew Bowd
content-type: application/pgp-signature; name="signature.asc"
content-disposition: attachment; filename="signature.asc"
Content-Length: 197
Download signature.asc
application/pgp-signature 197b

Message body not shown because it is not plain text.

MIME-Version: 1.0
In-Reply-To: <20110525143409.5cac3fe0 [...] siegfried.osrc.amd.com>
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
References: <20110525143409.5cac3fe0 [...] siegfried.osrc.amd.com>
Content-Type: text/plain; charset="UTF-8"
Message-ID: <rt-3.8.HEAD-18812-1306342044-1829.68461-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 165
Download (untitled) / with headers
text/plain 165b
You're trying to install an old version of Test::WWW::Mechanize. Latest is 1.32. Also, this is not the bug reporting queue. See the docs for how to report issues.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.