Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 56460
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: florent.angly [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.95
Fixed in: (no value)



Subject: Bundle documentation error?
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
X-RT-Original-Encoding: utf-8
Content-Type: multipart/mixed; boundary="----------=_1270900725-26541-260"
Content-Length: 0
Content-Type: text/plain; charset="UTF-8"
Content-Disposition: inline
Content-Transfer-Encoding: binary
Content-Length: 296
Download (untitled) / with headers
text/plain 296b
The documentation for Module::Install::Bundle states that it is required to add a line such as requires( perl => 5.005 ); to use the bundle_deps() and auto_bundle_deps() methods. When I do so, I get an error. In fact it seems like it is not necessary to require a specific version of Perl.
Subject: Makefile_test_3.PL
MIME-Version: 1.0
Content-Type: application/x-perl; name="Makefile_test_3.PL"
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline; filename="Makefile_test_3.PL"
Content-Transfer-Encoding: base64
Content-Length: 317
Download Makefile_test_3.PL
text/x-perl 317b
use inc::Module::Install; name 'GAAS'; all_from 'lib/GAAS.pm'; build_requires 'Test::More'; print "Requiring a specific Perl version, as the documentation says to do\n"; requires( perl => 5.005 ); print "Requiring a module that contains several *.pm files\n"; requires 'Error'; auto_bundle_deps; WriteAll;
Subject: log3.txt
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"; name="log3.txt"
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline; filename="log3.txt"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: ascii
Content-Length: 426
Download log3.txt
text/plain 426b
$ perl Makefile_test_3.PL include /home/floflooo/Work/GAAS/program/GAAS/inc/Module/Install.pm include inc/Module/Install/Metadata.pm include inc/Module/Install/Base.pm Requiring a specific Perl version, as the documentation says to do Requiring a module that contains several *.pm files include inc/Module/Install/Bundle.pm Cannot find bundle source for perl at /usr/local/share/perl/5.10.1/Module/Install/Bundle.pm line 38.
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Content-Type: text/plain; charset="UTF-8"
Message-ID: <rt-3.8.HEAD-26543-1270947380-1704.56460-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 487
Download (untitled) / with headers
text/plain 487b
Hi. Fixed the doc in the trunk. You should use perl_version('5.005') (or perl_version_from('lib/Foo/Bar.pm') instead FYI. Thanks. On 2010-4-10 Sat 07:58:45, FANGLY wrote: Show quoted text
> The documentation for Module::Install::Bundle states that it is
required Show quoted text
> to add a line such as > requires( perl => 5.005 ); > to use the bundle_deps() and auto_bundle_deps() methods. > > When I do so, I get an error. In fact it seems like it is not
necessary Show quoted text
> to require a specific version of Perl.
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Content-Type: text/plain; charset="UTF-8"
Message-ID: <rt-3.8.HEAD-6780-1273459502-401.56460-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 44
Hi. Closed this ticket as fixed too. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.