This queue is for tickets about the Module-Build-TAPArchive CPAN distribution.

Report information
The Basics
Id:
46632
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
JSWARTZ [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
  • 0.02
  • 0.03
  • 0.04
Fixed in:
(no value)



MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Type: text/plain
Charset: utf8
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 724
Test failures when installing under perl 5.8.8 on both OS X and Linux, for both 0.02 and 0.03. Creating new 'Build' script for 'Module-Build-TAPArchive' version '0.03' Copying lib/Module/Build/TAPArchive.pm -> blib/lib/Module/Build/TAPArchive.pm Manifying blib/lib/Module/Build/TAPArchive.pm -> blib/libdoc/Module::Build::TAPArchive.3 WONKO/Module-Build-TAPArchive-0.03.tar.gz ./Build -- OK Running Build test t/00-load.t .. ok t/01-base.t .. 1/14 # Failed test 'right number of passed tests' # at t/01-base.t line 51. # got: '0' # expected: '3' # Failed test 'right number of failed tests' # at t/01-base.t line 52. # got: '0' # expected: '1' # Looks like you failed 2 tests of 14.
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Charset: utf8
Content-Type: text/plain
Message-ID: <rt-3.6.HEAD-13950-1243982377-1469.46632-0-0@rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 352
On Tue Jun 02 18:34:14 2009, JSWARTZ wrote:
Show quoted text
> Test failures when installing under perl 5.8.8 on both OS X and Linux, > for both 0.02 and 0.03.
Can you run those tests with --verbose so I can see more of what is happening? Also what versions of the prereqs (Module::Build, TAP::Harness::Archive, Test::More, Capture::Tiny and File::Path) do you have?
MIME-Version: 1.0 (Apple Message framework v930.3)
X-Spam-Status: No, hits=-1.0 required=8.0 tests=RCVD_IN_DNSWL_LOW
In-Reply-To: <rt-3.6.HEAD-13950-1243982377-1469.46632-6-0@rt.cpan.org>
X-Mailer: Apple Mail (2.930.3)
References: <RT-Ticket-46632@rt.cpan.org> <rt-3.6.HEAD-13950-1243982377-1469.46632-6-0@rt.cpan.org>
Message-ID: <A8E708FB-4DB6-48F5-9202-D713804DDB0A@pobox.com>
Content-Type: text/plain; charset="utf-8"; delsp="yes"; format="flowed"
X-Sasl-Enc: eNWHnWk5rEoP+TgD2+5t6aMG00hd0jvHufMvII7TYmTg 1243983323
X-RT-Original-Encoding: utf-8
Received: from la.mx.develooper.com (x1.develooper.com [207.171.7.70]) by diesel.bestpractical.com (Postfix) with SMTP id F283E4D8171 for <bug-Module-Build-TAPArchive@rt.cpan.org>; Tue, 2 Jun 2009 18:55:33 -0400 (EDT)
Received: (qmail 8713 invoked by uid 103); 2 Jun 2009 22:55:33 -0000
Received: from x16.dev (10.0.100.26) by x1.dev with QMQP; 2 Jun 2009 22:55:33 -0000
Received: from out2.smtp.messagingengine.com (HELO out2.smtp.messagingengine.com) (66.111.4.26) by 16.mx.develooper.com (qpsmtpd/0.80) with ESMTP; Tue, 02 Jun 2009 15:55:28 -0700
Received: from compute1.internal (compute1.internal [10.202.2.41]) by out1.messagingengine.com (Postfix) with ESMTP id B70ED34A337 for <bug-Module-Build-TAPArchive@rt.cpan.org>; Tue, 2 Jun 2009 18:55:23 -0400 (EDT)
Received: from heartbeat1.messagingengine.com ([10.202.2.160]) by compute1.internal (MEProxy); Tue, 02 Jun 2009 18:55:23 -0400
Received: from [192.168.1.120] (dsl081-241-091.sfo1.dsl.speakeasy.net [64.81.241.91]) by mail.messagingengine.com (Postfix) with ESMTPSA id 2B9096A24 for <bug-Module-Build-TAPArchive@rt.cpan.org>; Tue, 2 Jun 2009 18:55:23 -0400 (EDT)
Delivered-To: cpan-bug+Module-Build-TAPArchive@diesel.bestpractical.com
Subject: Re: [rt.cpan.org #46632]
Return-Path: <swartz@pobox.com>
X-Spam-Check-BY: 16.mx.develooper.com
X-Original-To: bug-Module-Build-TAPArchive@rt.cpan.org
Date: Tue, 2 Jun 2009 15:55:22 -0700
X-Spam-Level: *
To: bug-Module-Build-TAPArchive@rt.cpan.org
Content-Transfer-Encoding: 7bit
From: Jonathan Swartz <swartz@pobox.com>
RT-Message-ID: <rt-3.6.HEAD-13950-1243983343-336.46632-0-0@rt.cpan.org>
Content-Length: 2974
Show quoted text
swartz> ./Build test --verbose
t/00-load....1..1 ok 1 - use Module::Build::TAPArchive; ok t/01-base....1..14 ok 1 - use Module::Build::TAPArchive; ok 2 - Module::Build::TAPArchive->can('new') Checking prerequisites... Looks good ok 3 - The object isa Module::Build ok 4 - The object isa Module::Build::TAPArchive ok 5 - default archive_file is test_archive.tar.gz Checking prerequisites... Looks good ok 6 - The object isa Module::Build ok 7 - The object isa Module::Build::TAPArchive ok 8 - override archive_file ok 9 - Module::Build::TAPArchive->can('ACTION_test') ok 10 - Module::Build::TAPArchive->can('ACTION_test_archive') ok 11 - created archive file ok 12 - The object isa TAP::Parser::Aggregator not ok 13 - right number of passed tests # Failed test 'right number of passed tests' # at t/01-base.t line 51. # got: '0' # expected: '3' not ok 14 - right number of failed tests # Failed test 'right number of failed tests' # at t/01-base.t line 52. # got: '0' # expected: '1' # Looks like you failed 2 tests of 14. dubious Test returned status 2 (wstat 512, 0x200) DIED. FAILED tests 13-14 Failed 2/14 tests, 85.71% okay Failed Test Stat Wstat Total Fail List of Failed ---------------------------------------------------------------------------------------------------------------------------------------------- t/01-base.t 2 512 14 2 13-14 Failed 1/2 test scripts. 2/15 subtests failed. Files=2, Tests=15, 1 wallclock secs ( 0.52 cusr + 0.15 csys = 0.67 CPU) Failed 1/2 test programs. 2/15 subtests failed.
Show quoted text
swartz> findpm Module::Build TAP::Harness::Archive Test::More
Capture::Tiny File::Path Module::Build - 0.33 - /Library/Perl/5.8.8/Module/Build.pm TAP::Harness::Archive - 0.13 - /Library/Perl/5.8.8/TAP/Harness/ Archive.pm Test::More - 0.86 - /System/Library/Perl/5.8.8/Test/More.pm Capture::Tiny - 0.06 - /Library/Perl/5.8.8/Capture/Tiny.pm File::Path - 1.08 - /System/Library/Perl/5.8.8/File/Path.pm
Show quoted text
swartz>
I upgraded to the latest versions of those modules, still fails in the same way.
Show quoted text
swartz> findpm Module::Build TAP::Harness::Archive Test::More
Capture::Tiny File::Path Module::Build - 0.33 - /Library/Perl/5.8.8/Module/Build.pm TAP::Harness::Archive - 0.13 - /Library/Perl/5.8.8/TAP/Harness/ Archive.pm Test::More - 0.88 - /System/Library/Perl/5.8.8/Test/More.pm Capture::Tiny - 0.06 - /Library/Perl/5.8.8/Capture/Tiny.pm File::Path - 2.07 - /System/Library/Perl/5.8.8/File/Path.pm On Jun 2, 2009, at 3:39 PM, Michael Peters via RT wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=46632 > > > On Tue Jun 02 18:34:14 2009, JSWARTZ wrote:
>> Test failures when installing under perl 5.8.8 on both OS X and >> Linux, >> for both 0.02 and 0.03.
> > Can you run those tests with --verbose so I can see more of what is > happening? Also what versions of the prereqs (Module::Build, > TAP::Harness::Archive, Test::More, Capture::Tiny and File::Path) do > you > have? > >
MIME-Version: 1.0
In-Reply-To: <rt-3.6.HEAD-13950-1243982377-1469.46632-0-0@rt.cpan.org>
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Charset: utf8
References: <rt-3.6.HEAD-13950-1243982377-1469.46632-0-0@rt.cpan.org>
Content-Type: text/plain
Message-ID: <rt-3.6.HEAD-14916-1249389226-250.46632-0-0@rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 167
JFYI: same problem building v0.03 with Perl 5.10.0 prereq versions: Module::Build 0.3300 TAP::Harness::Archive 0.13 Test::More 3.17 Capture::Tiny 0.06 File::Path 2.07
MIME-Version: 1.0
In-Reply-To: <rt-3.6.HEAD-14916-1249389226-250.46632-0-0@rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-3.6.HEAD-13950-1243982377-1469.46632-0-0@rt.cpan.org> <rt-3.6.HEAD-14916-1249389226-250.46632-0-0@rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-20546-1474101746-1451.46632-0-0@rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 435
On 2009-08-04 08:33:46, snowcrash78 wrote:
Show quoted text
> JFYI: same problem building v0.03 with Perl 5.10.0 > > prereq versions: > Module::Build 0.3300 > TAP::Harness::Archive 0.13 > Test::More 3.17 > Capture::Tiny 0.06 > File::Path 2.07
With 0.04 the test also fails: Errors in testing. Cannot continue. # Looks like your test exited with 29 just after 10. t/01-base.t .. Dubious, test returned 29 (wstat 7424, 0x1d00) Failed 4/14 subtests


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.