Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the PPI CPAN distribution.

Report information
The Basics
Id: 44014
Status: resolved
Priority: 0/
Queue: PPI

People
Owner: Nobody in particular
Requestors: ANIRVAN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.202_03
Fixed in: (no value)



Subject: PPI accidentally stopped working with Perl 5.6
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Type: text/plain
Charset: utf8
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 925
Download (untitled) / with headers
text/plain 925b
Jumping from release 1.202_01 to 1.202_03, something happened in the code that caused PPI to stop working on Perl 5.6. I presume this isn't intentional, since the Changes file from 1.202_03 states "Upgrading explicit Perl dependency to 5.006" Because PPI is broken, projects that make use of current version of PPI (e.g. Perl::Critic also fail on the Perl 5.6 platform). You can see the difference on the Testers Matrix: http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_01 http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_03 Here are example test failure reports: http://www.nntp.perl.org/group/perl.cpan.testers/2008/05/msg1452822.html http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2577062.html http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2578102.html If needed, I'd be happy to help you in testing possible solutions under Perl 5.6. Thank you.
MIME-Version: 1.0
X-Spam-Status: No, hits=0.0 required=8.0 tests=DK_SIGNED,SPF_PASS
In-Reply-To: <rt-3.6.HEAD-22416-1236715138-1425.44014-4-0 [...] rt.cpan.org>
References: <RT-Ticket-44014 [...] rt.cpan.org> <rt-3.6.HEAD-22416-1236715138-1425.44014-4-0 [...] rt.cpan.org>
Message-ID: <b8cb49a40903101834p13d439f4s4f7ad015961b78b [...] mail.gmail.com>
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: utf-8
Received: from la.mx.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id 976B023C115 for <bug-PPI [...] rt.cpan.org>; Tue, 10 Mar 2009 21:34:24 -0400 (EDT)
Received: (qmail 10392 invoked by uid 103); 11 Mar 2009 01:34:24 -0000
Received: from x16.dev (10.0.100.26) by x1.dev with QMQP; 11 Mar 2009 01:34:24 -0000
Received: from rv-out-0506.google.com (HELO rv-out-0506.google.com) (209.85.198.238) by 16.mx.develooper.com (qpsmtpd/0.43rc1) with ESMTP; Tue, 10 Mar 2009 18:34:20 -0700
Received: by rv-out-0506.google.com with SMTP id l9so2567795rvb.33 for <bug-PPI [...] rt.cpan.org>; Tue, 10 Mar 2009 18:34:17 -0700 (PDT)
Received: by 10.141.36.10 with SMTP id o10mr4065538rvj.152.1236735257207; Tue, 10 Mar 2009 18:34:17 -0700 (PDT)
Delivered-To: cpan-bug+PPI [...] diesel.bestpractical.com
Subject: Re: [rt.cpan.org #44014] PPI accidentally stopped working with Perl 5.6
Domainkey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=lmSIS6HPoBS+Mv+USJ3WNTHrVOKRZdwv0d5WMZOMHjHhs9VQt28lu6m8rqLIHVL5+D e1/v8H3QQhvDd+wUNdOasEoPWM+IobidznNtW/Uw6HhSRj2egMMOlFDuGl+Vf6VzYdvx 4lDvjyyHGPeCO1+TpBEXs3JyrEohUMRsWLDRI=
Return-Path: <adamkennedybackup [...] gmail.com>
Dkim-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=2KcS7oK8WlmVsTcrQeZEL5OwjoVyCLGbICyV9QhGb0o=; b=ssrjyygMwL9DWu2xaHBS4BolUg6LsWLdlsrYvUfjga2eITBRMhwquWO8V22BAbsK5q dKwz8DtXkqk2H205QNXpofkxn5cLgKRRlZIqODAXl8y8MU6rFkv6+PyNEk9ty/kJY1lf BpEM5F9Zg27dSinAm3IBE448n/i2sc0ddJZ2s=
X-Spam-Check-BY: 16.mx.develooper.com
X-Original-To: bug-PPI [...] rt.cpan.org
Date: Wed, 11 Mar 2009 12:34:17 +1100
X-Spam-Level: *
To: bug-PPI [...] rt.cpan.org
Content-Transfer-Encoding: quoted-printable
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
RT-Message-ID: <rt-3.6.HEAD-22416-1236735268-1827.44014-0-0 [...] rt.cpan.org>
Content-Length: 1559
Download (untitled) / with headers
text/plain 1.5k
Unfortunately, I don't have convenient access to a 5.6 install to see why this is the case... I'll see if I can work out some form of access. Adam K 2009/3/11 Anirvan Chatterjee via RT <bug-PPI@rt.cpan.org>: Show quoted text
> Tue Mar 10 15:58:58 2009: Request 44014 was acted upon. > Transaction: Ticket created by ANIRVAN >       Queue: PPI >     Subject: PPI accidentally stopped working with Perl 5.6 >   Broken in: 1.202_03 >    Severity: Normal >       Owner: Nobody >  Requestors: ANIRVAN@cpan.org >      Status: new >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=44014 > > > > Jumping from release 1.202_01 to 1.202_03, something happened in the > code that caused PPI to stop working on Perl 5.6. I presume this isn't > intentional, since the Changes file from 1.202_03 states "Upgrading > explicit Perl dependency to 5.006" > > Because PPI is broken, projects that make use of current version of PPI > (e.g. Perl::Critic also fail on the Perl 5.6 platform). > > You can see the difference on the Testers Matrix: > http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_01 > http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_03 > > Here are example test failure reports: > http://www.nntp.perl.org/group/perl.cpan.testers/2008/05/msg1452822.html > http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2577062.html > http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2578102.html > > If needed, I'd be happy to help you in testing possible solutions under > Perl 5.6. Thank you. >
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Content-Type: text/plain; charset="UTF-8"
Message-ID: <rt-3.8.HEAD-14824-1266738410-337.44014-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 56
Minimum version of Perl moved to 5.6, and is now tested.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.