Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 29874
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.99_15
Fixed in: 1.01



Subject: More regexps for perl version detection
MIME-Version: 1.0
X-Mailer: MIME-tools 5.418 (Entity 5.418)
Content-Type: text/plain; charset="utf8"
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 303
Download (untitled) / with headers
text/plain 303b
Module::Install generates the following error message if the perl version is to low: ERROR: perl: Version 5.00505 is installed, but we need version >= 5.008002 at Makefile.PL line 158. This is currently not recognized in CPAN::Reporter for the "perl version too low" error grade. Regards, Slaven
MIME-Version: 1.0
X-Spam-Status: No, hits=-2.6 required=8.0 tests=BAYES_00,DKIM_SIGNED,DKIM_VERIFIED,DK_SIGNED,SPF_PASS
In-Reply-To: <rt-3.6.HEAD-6553-1191967309-551.29874-4-0 [...] rt.cpan.org>
Content-Disposition: inline
References: <RT-Ticket-29874 [...] rt.cpan.org> <rt-3.6.HEAD-6553-1191967309-551.29874-4-0 [...] rt.cpan.org>
Content-Type: text/plain; charset=UTF-8
X-RT-Original-Encoding: utf-8
Received: from la.mx.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id B4C984D80A5 for <bug-CPAN-Reporter [...] rt.cpan.org>; Wed, 10 Oct 2007 06:37:53 -0400 (EDT)
Received: (qmail 26542 invoked by alias); 10 Oct 2007 10:37:53 -0000
Received: from rv-out-0910.google.com (HELO rv-out-0910.google.com) (209.85.198.190) by la.mx.develooper.com (qpsmtpd/0.28) with ESMTP; Wed, 10 Oct 2007 03:37:41 -0700
Received: by rv-out-0910.google.com with SMTP id k20so153980rvb for <bug-CPAN-Reporter [...] rt.cpan.org>; Wed, 10 Oct 2007 03:37:38 -0700 (PDT)
Received: by 10.140.128.3 with SMTP id a3mr190501rvd.1192012058709; Wed, 10 Oct 2007 03:27:38 -0700 (PDT)
Received: by 10.140.127.12 with HTTP; Wed, 10 Oct 2007 03:27:38 -0700 (PDT)
Delivered-To: cpan-bug+cpan-reporter [...] diesel.bestpractical.com
Subject: Re: [rt.cpan.org #29874] More regexps for perl version detection
Domainkey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:sender:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references:x-google-sender-auth; b=Jf5MdlD5MR/ttTlqtkdQy3q0s0igc3RpKF9+2aoiT5dznMhXSlDpVp8mgdo8ASB6dcjVK7dwSo1NRqyyTvDJxpzHK3QZK1DsX3nK0Lt8f5Wwhek9q8yIf/pzmGEPEglvrNab631g6Zw0F60MDfQ7AtfLZ8I6nUGG3UE/6LqppyQ=
Return-Path: <xdaveg [...] gmail.com>
Dkim-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:sender:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references:x-google-sender-auth; bh=n6dl2mNbjWFrmLQ/hh/+QEAdNBQTXCKdcQFz4mNSi0s=; b=nL3ODM5mm33W4ak5Ws8J7YMnFp6Uzbw49dTVA78X0OQUnlyfLi1ugK/RzCx9odi4PHiTzZZu5hdkZegVPmGRMvHlh1Z5W40eW/vfv0Dz6+pRkAqupAobyKUoQsJAYC2uI4vP7wpjboEzPtqWmwG5TZn/NYt2U4Aim2qqiKfR9Gk=
X-Spam-Check-BY: la.mx.develooper.com
X-Original-To: bug-CPAN-Reporter [...] rt.cpan.org
X-Google-Sender-Auth: 8fbc3afea2572722
Sender: xdaveg [...] gmail.com
Date: Wed, 10 Oct 2007 06:27:38 -0400
Message-Id: <5d4beb40710100327j31a06cadt7ade940ee8c54925 [...] mail.gmail.com>
To: bug-CPAN-Reporter [...] rt.cpan.org
Content-Transfer-Encoding: 7bit
From: "David Golden" <dagolden [...] cpan.org>
X-RT-Original-Encoding: utf-8
RT-Message-ID: <rt-3.6.HEAD-6550-1192012700-1366.29874-0-0 [...] rt.cpan.org>
Content-Length: 370
Download (untitled) / with headers
text/plain 370b
On 10/9/07, Slaven_Rezic via RT <bug-CPAN-Reporter@rt.cpan.org> wrote: Show quoted text
> Module::Install generates the following error message if the perl version > is to low: > > ERROR: perl: Version 5.00505 is installed, but we need version >= > 5.008002 at Makefile.PL line 158.
Thanks. Could you please give me an example distribution with that behavior for me to examine? David
CC: srezic [...] cpan.org
MIME-Version: 1.0
X-Spam-Status: No, hits=-2.6 required=8.0 tests=BAYES_00
In-Reply-To: <rt-3.6.HEAD-6550-1192012700-1366.29874-6-0 [...] rt.cpan.org>
References: <RT-Ticket-29874 [...] rt.cpan.org> <rt-3.6.HEAD-6553-1191967309-551.29874-4-0 [...] rt.cpan.org> <5d4beb40710100327j31a06cadt7ade940ee8c54925 [...] mail.gmail.com> <rt-3.6.HEAD-6550-1192012700-1366.29874-6-0 [...] rt.cpan.org>
Importance: Normal
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: iso-8859-2
Received: from la.mx.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id 90CA14D80A5 for <bug-CPAN-Reporter [...] rt.cpan.org>; Wed, 10 Oct 2007 07:18:22 -0400 (EDT)
Received: (qmail 22674 invoked by alias); 10 Oct 2007 11:18:22 -0000
Received: from mail3.ixls.de (HELO mail3.ixls.de) (78.47.208.109) by la.mx.develooper.com (qpsmtpd/0.28) with ESMTP; Wed, 10 Oct 2007 04:18:18 -0700
Received: from mail3.ixls.de ([78.47.208.109] helo=mail.rezic.de) by mail3.ixls.de with esmtp (Exim 4.63) id 1IfZZf-0005lX-LF; Wed, 10 Oct 2007 13:17:59 +0200
Received: from 89.247.121.141 (SquirrelMail authenticated user mail [...] rezic.de) by mail.rezic.de with HTTP; Wed, 10 Oct 2007 13:17:59 +0200 (CEST)
Delivered-To: cpan-bug+cpan-reporter [...] diesel.bestpractical.com
User-Agent: SquirrelMail/1.4.9a
Subject: Re: [rt.cpan.org #29874] More regexps for perl version detection
Return-Path: <slaven [...] rezic.de>
X-Spam-Check-BY: la.mx.develooper.com
X-Original-To: bug-CPAN-Reporter [...] rt.cpan.org
X-Priority: 3 (Normal)
Date: Wed, 10 Oct 2007 13:17:59 +0200 (CEST)
Message-Id: <49413.89.247.121.141.1192015079.squirrel [...] mail.rezic.de>
To: bug-CPAN-Reporter [...] rt.cpan.org
Content-Transfer-Encoding: 8bit
From: slaven [...] rezic.de
X-RT-Original-Encoding: utf-8
RT-Message-ID: <rt-3.6.HEAD-6544-1192015147-1693.29874-0-0 [...] rt.cpan.org>
Content-Length: 563
Download (untitled) / with headers
text/plain 563b
Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=29874 > > > On 10/9/07, Slaven_Rezic via RT <bug-CPAN-Reporter@rt.cpan.org> wrote:
>> Module::Install generates the following error message if the perl >> version >> is to low: >> >> ERROR: perl: Version 5.00505 is installed, but we need version >= >> 5.008002 at Makefile.PL line 158.
> > Thanks. Could you please give me an example distribution with that > behavior for me to examine? >
An example would be: http://search.cpan.org/CPAN/authors/id/G/GR/GRUBER/DBIx-Perlish-0.29.tar.gz Regards, Slaven


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.