Skip Menu |
 

This queue is for tickets about the CGI-Session CPAN distribution.

Report information
The Basics
Id: 21981
Status: resolved
Priority: 0/
Queue: CGI-Session

People
Owner: RSAVAGE [...] cpan.org
Requestors: erwan [...] mas.nom.fr
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



MIME-Version: 1.0
X-Spam-Status: No, hits=-2.6 required=8.0 tests=BAYES_00,SPF_PASS,UNPARSEABLE_RELAY
Content-Disposition: inline
Received-SPF: pass (x1.develooper.com: domain of erwan [...] mas.nom.fr designates 62.93.224.43 as permitted sender)
Content-Type: multipart/mixed; boundary="Pd0ReVV5GZGQvF3a"
Received: from la.mx.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id D2A794D801A for <bug-cgi-session [...] rt.cpan.org>; Mon, 9 Oct 2006 19:12:17 -0400 (EDT)
Received: (qmail 30619 invoked by alias); 9 Oct 2006 23:12:17 -0000
Received: from pulsar.zoreil.com (HELO pulsar.zoreil.com) (62.93.224.43) by la.mx.develooper.com (qpsmtpd/0.28) with ESMTP; Mon, 09 Oct 2006 16:12:13 -0700
Received: from pulsar.zoreil.com (IDENT:I/r08k76dNtfeBnmOlKUuVa4mlSf4x7H [...] localhost [127.0.0.1]) by pulsar.zoreil.com (8.12.10/8.12.10) with ESMTP id k99NC4gP009271 for <bug-cgi-session [...] rt.cpan.org>; Tue, 10 Oct 2006 01:12:04 +0200
Received: (from uucp [...] localhost) by pulsar.zoreil.com (8.12.10/8.12.10) id k99NC4wW009269 for bug-cgi-session [...] rt.cpan.org; Tue, 10 Oct 2006 01:12:04 +0200
Received: by voyageur.mas.nom.fr (Postfix, from userid 1000) id 8A25CDA48; Tue, 10 Oct 2006 01:11:48 +0200 (CEST)
Delivered-To: cpan-bug+cgi-session [...] diesel.bestpractical.com
Subject: Bug with utf8
User-Agent: Mutt/1.5.6+20040722i
Return-Path: <erwan [...] mas.nom.fr>
X-Original-To: bug-cgi-session [...] rt.cpan.org
X-Spam-Check-BY: la.mx.develooper.com
Date: Tue, 10 Oct 2006 01:11:48 +0200
Message-Id: <20061009231148.GI13185 [...] voyageur.nic.fr>
To: bug-CGI-Session [...] rt.cpan.org
From: Erwan MAS <erwan [...] mas.nom.fr>
Content-Length: 0
content-type: text/plain; charset="utf-8"
Content-Disposition: inline
X-RT-Original-Encoding: us-ascii
Content-Length: 490
Download (untitled) / with headers
text/plain 490b
Hello , The program in attachement does not work . But when i remove the line "use encoding 'utf8';" the program work . Perhaps I had missed some thing. -- Show quoted text
____________________________________________________________ / Erwan MAS /\ | mailto:erwan@mas.nom.fr |_/ ___|________________________________________________________ | \___________________________________________________________\__/
Content-Type: text/x-perl; charset=us-ascii
content-disposition: attachment; filename="bug_utf8_cgi_session.pl"
X-RT-Original-Encoding: us-ascii
Content-Length: 1353

Message body is not shown because sender requested not to inline it.

MIME-Version: 1.0
X-Spam-Status: No, hits=-2.6 required=8.0 tests=BAYES_00,SPF_PASS,UNPARSEABLE_RELAY
In-Reply-To: <rt-3.6.HEAD-9978-1160435544-1732.21981-3-0 [...] rt.cpan.org>
Content-Disposition: inline
Received-SPF: pass (x1.develooper.com: domain of erwan [...] mas.nom.fr designates 62.93.224.43 as permitted sender)
References: <RT-Ticket-21981 [...] rt.cpan.org> <20061009231148.GI13185 [...] voyageur.nic.fr> <rt-3.6.HEAD-9978-1160435544-1732.21981-3-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: us-ascii
Received: from la.mx.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id 0C1E14D801A for <bug-cgi-session [...] rt.cpan.org>; Mon, 9 Oct 2006 19:17:18 -0400 (EDT)
Received: (qmail 587 invoked by alias); 9 Oct 2006 23:17:18 -0000
Received: from pulsar.zoreil.com (HELO pulsar.zoreil.com) (62.93.224.43) by la.mx.develooper.com (qpsmtpd/0.28) with ESMTP; Mon, 09 Oct 2006 16:17:14 -0700
Received: from pulsar.zoreil.com (IDENT:GFQ1sS1mGxBRQLa0ppro/nbmUzmoHQJv [...] localhost [127.0.0.1]) by pulsar.zoreil.com (8.12.10/8.12.10) with ESMTP id k99NH3gP009773 for <bug-cgi-session [...] rt.cpan.org>; Tue, 10 Oct 2006 01:17:03 +0200
Received: (from uucp [...] localhost) by pulsar.zoreil.com (8.12.10/8.12.10) id k99NH39b009771 for bug-cgi-session [...] rt.cpan.org; Tue, 10 Oct 2006 01:17:03 +0200
Received: by voyageur.mas.nom.fr (Postfix, from userid 1000) id 01D77DB28; Tue, 10 Oct 2006 01:16:16 +0200 (CEST)
Delivered-To: cpan-bug+cgi-session [...] diesel.bestpractical.com
Subject: Re: [rt.cpan.org #21981] AutoReply: Bug with utf8
User-Agent: Mutt/1.5.6+20040722i
Return-Path: <erwan [...] mas.nom.fr>
X-Spam-Check-BY: la.mx.develooper.com
X-Original-To: bug-cgi-session [...] rt.cpan.org
Date: Tue, 10 Oct 2006 01:16:16 +0200
Message-Id: <20061009231616.GJ13185 [...] voyageur.nic.fr>
To: bug-CGI-Session [...] rt.cpan.org
From: Erwan MAS <erwan [...] mas.nom.fr>
X-RT-Original-Encoding: utf-8
RT-Message-ID: <rt-3.6.HEAD-10023-1160435840-1663.21981-0-0 [...] rt.cpan.org>
Content-Length: 1850
Download (untitled) / with headers
text/plain 1.8k
I paste de programm in the mail . --------------------------------------------------------------- #!/usr/bin/perl #---------------------------------------------------------------------------------------------- use encoding 'utf8'; #---------------------------------------------------------------------------------------------- use CGI::Session; #---------------------------------------------------------------------------------------------- sub create_ses { my $session = new CGI::Session("driver:File", undef, {Directory=>'/tmp'}); $session->param(-name=>'user', -value=>"coucou"); $session->param(-name=>'passwd', -value=>"cpan"); $session->expire('+30m'); my $sid=$session->id(); $session->close() ; return $sid ; } #---------------------------------------------------------------------------------------------- sub reopen_ses { my $sid=shift ; my $session = new CGI::Session("driver:File", $sid , {Directory=>'/tmp'}); # if ( $session ) { return 'OK' ; $session->close() ; } else { printf STDERR "can not create a new session '%s'",CGI::Session->errstr() ; } return undef ; } #---------------------------------------------------------------------------------------------- my $t=&create_ses() ; if ( $t ) { my $tt=&reopen_ses($t) ; if ( $tt ) { print STDERR "test is ok\n" ; } } #---------------------------------------------------------------------------------------------- --------------------------------------------------------------- -- Show quoted text
____________________________________________________________ / Erwan MAS /\ | mailto:erwan@mas.nom.fr |_/ ___|________________________________________________________ | \___________________________________________________________\__/
MIME-Version: 1.0
X-Spam-Status: No, hits=1.2 required=8.0 tests=BAYES_05,DATE_IN_PAST_24_48,SPF_SOFTFAIL
In-Reply-To: <rt-3.6.HEAD-9978-1160435544-467.21981-4-0 [...] rt.cpan.org>
Received-SPF: softfail (x1.develooper.com: transitioning domain of mark [...] summersault.com does not designate 12.161.104.4 as permitted sender)
References: <RT-Ticket-21981 [...] rt.cpan.org> <20061009231148.GI13185 [...] voyageur.nic.fr> <rt-3.6.HEAD-9978-1160435544-467.21981-4-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: ISO-8859-1
Received: from la.mx.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id 910254D8108 for <bug-CGI-Session [...] rt.cpan.org>; Sun, 22 Oct 2006 16:14:54 -0400 (EDT)
Received: (qmail 8903 invoked by alias); 22 Oct 2006 20:14:53 -0000
Received: from mail.parallax.ws (HELO mail.parallax.ws) (12.161.104.4) by la.mx.develooper.com (qpsmtpd/0.28) with ESMTP; Sun, 22 Oct 2006 13:14:50 -0700
Received: (qmail 42974 invoked by uid 89); 22 Oct 2006 20:14:21 -0000
Received: by simscan 1.2.0 ppid: 42968, pid: 42970, t: 1.1599s scanners: clamav: 0.87/m:34/d:1109 spam: 3.1.0
Received: from unknown (HELO ?192.168.1.101?) (12.176.101.89) by 0 with SMTP; 22 Oct 2006 20:14:20 -0000
Delivered-To: cpan-bug+cgi-session [...] diesel.bestpractical.com
Subject: Re: [rt.cpan.org #21981] Bug with utf8
User-Agent: Thunderbird 1.5 (X11/20060405)
Return-Path: <mark [...] summersault.com>
X-Spam-Check-BY: la.mx.develooper.com
X-Original-To: bug-CGI-Session [...] rt.cpan.org
X-Old-Spam-Status: No, score=0.4 required=5.0 tests=AWL,DATE_IN_PAST_24_48 autolearn=disabled version=3.1.0
Date: Fri, 20 Oct 2006 19:03:08 -0500
X-Spam-Level:
Message-Id: <453963BC.3020009 [...] summersault.com>
X-Spam-Checker-Version: SpamAssassin 3.1.0 (2005-09-13) on ns1.parallax.ws
To: bug-CGI-Session [...] rt.cpan.org
X-Enigmail-Version: 0.94.1.0
Content-Transfer-Encoding: 7bit
From: Mark Stosberg <mark [...] summersault.com>
X-RT-Original-Encoding: utf-8
RT-Message-ID: <rt-3.6.HEAD-10325-1161548098-1970.21981-0-0 [...] rt.cpan.org>
Content-Length: 949
Download (untitled) / with headers
text/plain 949b
Erwan MAS via RT wrote: Show quoted text
> > Hello , > > The program in attachement does not work . > But when i remove the line "use encoding 'utf8';" the program work . > > Perhaps I had missed some thing.
Erwan, I'm interested to see if we can resolve this, because I want to make sure that CGI::Session works with UTF. However, it's not something I need in my own work, it looks like you do. Would you be willing to help? First, see if you can keep reducing your test script further to see if you can isolate the problem, ideally as a "Test::More" style test script we could add to the test suite. If you do isolate the problem, perhaps you could take the next step and see if could also fix the bug in the source code. If you get stuck at any point, ask for help in the CGI::Session users mailing list. In any case, I'll thank you for the bug report. Someone will look into it further eventually if you don't. Mark -- http://mark.stosberg.com/
MIME-Version: 1.0
In-Reply-To: <rt-3.6.HEAD-10325-1161548098-1970.21981-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.418 (Entity 5.418)
Content-Disposition: inline
Charset: utf8
References: <RT-Ticket-21981 [...] rt.cpan.org> <20061009231148.GI13185 [...] voyageur.nic.fr> <rt-3.6.HEAD-9978-1160435544-467.21981-4-0 [...] rt.cpan.org> <453963BC.3020009 [...] summersault.com> <rt-3.6.HEAD-10325-1161548098-1970.21981-0-0 [...] rt.cpan.org>
Message-Id: <rt-3.6.HEAD-8903-1205634093-18.21981-0-0 [...] rt.cpan.org>
Content-Type: text/plain
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Original-Encoding: utf-8
Content-Length: 1120
I'm giving this ticket to Ron Savage who has started to look into this. Mark On Sun Oct 22 16:14:58 2006, mark@summersault.com wrote: Show quoted text
> Erwan MAS via RT wrote:
> > > > Hello , > > > > The program in attachement does not work . > > But when i remove the line "use encoding 'utf8';" the program work . > > > > Perhaps I had missed some thing.
> > Erwan, > > I'm interested to see if we can resolve this, because I want to make > sure that CGI::Session works with UTF. However, it's not something I > need in my own work, it looks like you do. Would you be willing to help? > > First, see if you can keep reducing your test script further to see if > you can isolate the problem, ideally as a "Test::More" style test script > we could add to the test suite. > > If you do isolate the problem, perhaps you could take the next step and > see if could also fix the bug in the source code. > > If you get stuck at any point, ask for help in the CGI::Session users > mailing list. > > In any case, I'll thank you for the bug report. Someone will look into > it further eventually if you don't. > > Mark >
MIME-Version: 1.0
In-Reply-To: <20061009231148.GI13185 [...] voyageur.nic.fr>
X-Mailer: MIME-tools 5.418 (Entity 5.418)
Content-Disposition: inline
Charset: utf8
References: <20061009231148.GI13185 [...] voyageur.nic.fr>
Message-Id: <rt-3.6.HEAD-8903-1205635973-88.21981-0-0 [...] rt.cpan.org>
Content-Type: text/plain
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Original-Encoding: utf-8
Content-Length: 754
Download (untitled) / with headers
text/plain 754b
I see there's a fix for this in SVN and some passing tests. Would it be too much hassle to make this warning the test emits go away? Some users could take it to indicate a problem. I looked at distributing Test::Warn for this purpose, but it requires a string of dependencies itself. Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval 19) line 1. Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval 19) line 1. (in cleanup) Can't locate object method "renewed" via package "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at (eval 19) line 1. (in cleanup) Can't locate object method "renewed" via package "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at (eval 19) line 1.
MIME-Version: 1.0
X-Spam-Status: No, hits=-2.6 required=8.0 tests=BAYES_00
In-Reply-To: <rt-3.6.HEAD-8903-1205635973-88.21981-5-0 [...] rt.cpan.org>
X-Mailer: Evolution 2.12.3
References: <RT-Ticket-21981 [...] rt.cpan.org> <20061009231148.GI13185 [...] voyageur.nic.fr> <rt-3.6.HEAD-8903-1205635973-88.21981-5-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
X-RT-Original-Encoding: ascii
Received: from x1.develooper.com (x1.develooper.com [63.251.223.170]) by diesel.bestpractical.com (Postfix) with SMTP id D25DC4D8018 for <bug-CGI-Session [...] rt.cpan.org>; Sun, 16 Mar 2008 01:30:10 -0400 (EDT)
Received: (qmail 17699 invoked from network); 16 Mar 2008 05:30:09 -0000
Received: from x16.dev (10.0.100.26) by x1.dev with QMQP; 16 Mar 2008 05:30:09 -0000
Received: from hosted08.westnet.com.au (HELO hosted08.westnet.com.au) (203.10.1.225) by 16.mx.develooper.com (qpsmtpd/0.43rc1) with ESMTP; Sat, 15 Mar 2008 22:30:06 -0700
Received: from hosted08.westnet.com.au (hosted08.westnet.com.au [127.0.0.1]) by hosted08.westnet.com.au (Postfix) with SMTP id 876EA3B9318 for <bug-CGI-Session [...] rt.cpan.org>; Sun, 16 Mar 2008 14:30:00 +0900 (WST)
Received: from [192.168.100.4] (dsl-58-6-176-29.nsw.westnet.com.au [58.6.176.29]) by hosted08.westnet.com.au (Postfix) with ESMTP id C8C513B93C1 for <bug-CGI-Session [...] rt.cpan.org>; Sun, 16 Mar 2008 14:29:59 +0900 (WST)
Delivered-To: cpan-bug+CGI-Session [...] diesel.bestpractical.com
Subject: Re: [rt.cpan.org #21981] Bug with utf8
X-PMX-Branch: TNG-Outgoing
Return-Path: <ron [...] savage.net.au>
X-Spam-Check-BY: 16.mx.develooper.com
X-Original-To: bug-CGI-Session [...] rt.cpan.org
Date: Sun, 16 Mar 2008 16:33:07 +1100
X-Spam-Level: *
Message-Id: <1205645587.4323.35.camel [...] zoe.savage.net.au>
To: bug-CGI-Session [...] rt.cpan.org
Content-Transfer-Encoding: 7bit
From: Ron Savage <ron [...] savage.net.au>
X-RT-Original-Encoding: utf-8
RT-Message-ID: <rt-3.6.HEAD-8924-1205645418-467.21981-0-0 [...] rt.cpan.org>
Content-Length: 2220
Download (untitled) / with headers
text/plain 2.1k
Hi Mark On Sat, 2008-03-15 at 22:52 -0400, MARKSTOS via RT wrote: Show quoted text
> Queue: CGI-Session > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=21981 > > > I see there's a fix for this in SVN and some passing tests. Would it be > too much hassle to make this warning the test emits go away? Some users > could take it to indicate a problem. > > I looked at distributing Test::Warn for this purpose, but it requires a > string of dependencies itself. > > Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval > 19) line 1. > Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval > 19) line 1. > (in cleanup) Can't locate object method "renewed" via package > "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at (eval 19) > line 1. > (in cleanup) Can't locate object method "renewed" via package > "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at (eval 19) > line 1.
My first thought was to patch the text associated with the test to add: Warnings expected. Consult docs re 'utf8' I'll do that now in SVN. Also, let me copy here for the record the rationale I posted to the mailing list for these warnings: <==8><==> The new test program I've written passes all tests, but still emits a deliberate warning message. Here's my thinking: o Tests and installation should not fail in all those cases people are not using utf8 o References to utf8 are on RT, the docs (with my patch), and this email list's archive, to help people diagnose problems o My new test program passes all tests so automated testing and installation can continue, assuming all other problems are fixed, of course o The new test emits a warning so anyone watching the tests' progress will see a reference to utf8 being problematic o Clearly I do not have a solution to this problem, but I have no intention of diving into the innards of utf8-related code, so I see the new test as simply giving people more warning about utf8 problems than they've had up to now <==8><==> Sure, users can be confused, but to me that's better than having their programs behave mysteriously over a known problem. -- Ron Savage ron@savage.net.au http://savage.net.au/index.html
MIME-Version: 1.0
In-Reply-To: <rt-3.6.HEAD-8924-1205645418-467.21981-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.418 (Entity 5.418)
Content-Disposition: inline
Charset: utf8
References: <RT-Ticket-21981 [...] rt.cpan.org> <20061009231148.GI13185 [...] voyageur.nic.fr> <rt-3.6.HEAD-8903-1205635973-88.21981-5-0 [...] rt.cpan.org> <1205645587.4323.35.camel [...] zoe.savage.net.au> <rt-3.6.HEAD-8924-1205645418-467.21981-0-0 [...] rt.cpan.org>
Message-Id: <rt-3.6.HEAD-24876-1207417882-428.21981-0-0 [...] rt.cpan.org>
Content-Type: text/plain
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Original-Encoding: utf-8
Content-Length: 2876
Download (untitled) / with headers
text/plain 2.8k
Hi, I had also this problem, but when using Storable as serializer and MySQL for storage. I changed the serializer to yaml and the problem was solved. I know this is just a workaround... If this is of any help: My dsn: DBI:mysql:database=blabala;host=localhost;mysql_enable_utf8=1 note the 'mysql_enable_utf8=1' and I use also DBIx::Simple::UTF8Columns which automatically encodes the data sent to the database. But Storable files/data are binary and are not supposed to be utf8 upgraded. Since YAML dumps are just text there is no problem. On Sun Mar 16 01:30:18 2008, ron@savage.net.au wrote: Show quoted text
> Hi Mark > > On Sat, 2008-03-15 at 22:52 -0400, MARKSTOS via RT wrote:
> > Queue: CGI-Session > > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=21981 > > > > > I see there's a fix for this in SVN and some passing tests. Would it be > > too much hassle to make this warning the test emits go away? Some users > > could take it to indicate a problem. > > > > I looked at distributing Test::Warn for this purpose, but it requires a > > string of dependencies itself. > > > > Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval > > 19) line 1. > > Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval > > 19) line 1. > > (in cleanup) Can't locate object method "renewed" via package > > "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at (eval 19) > > line 1. > > (in cleanup) Can't locate object method "renewed" via package > > "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at (eval 19) > > line 1.
> > My first thought was to patch the text associated with the test to add: > > Warnings expected. Consult docs re 'utf8' > > I'll do that now in SVN. > > Also, let me copy here for the record the rationale I posted to the > mailing list for these warnings: > > <==8><==> > The new test program I've written passes all tests, but still emits a > deliberate warning message. Here's my thinking: > > o Tests and installation should not fail in all those cases people are > not using utf8 > > o References to utf8 are on RT, the docs (with my patch), and this email > list's archive, to help people diagnose problems > > o My new test program passes all tests so automated testing and > installation can continue, assuming all other problems are fixed, of > course > > o The new test emits a warning so anyone watching the tests' progress > will see a reference to utf8 being problematic > > o Clearly I do not have a solution to this problem, but I have no > intention of diving into the innards of utf8-related code, so I see the > new test as simply giving people more warning about utf8 problems than > they've had up to now > <==8><==> > > Sure, users can be confused, but to me that's better than having their > programs behave mysteriously over a known problem. >
MIME-Version: 1.0
In-Reply-To: <rt-3.6.HEAD-24876-1207417882-428.21981-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.426 (Entity 5.426)
Content-Disposition: inline
Charset: utf8
References: <RT-Ticket-21981 [...] rt.cpan.org> <20061009231148.GI13185 [...] voyageur.nic.fr> <rt-3.6.HEAD-8903-1205635973-88.21981-5-0 [...] rt.cpan.org> <1205645587.4323.35.camel [...] zoe.savage.net.au> <rt-3.6.HEAD-8924-1205645418-467.21981-0-0 [...] rt.cpan.org> <rt-3.6.HEAD-24876-1207417882-428.21981-0-0 [...] rt.cpan.org>
Message-Id: <rt-3.6.HEAD-11898-1225510841-686.21981-0-0 [...] rt.cpan.org>
Content-Type: text/plain
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 3217
Download (untitled) / with headers
text/plain 3.1k
BEROV, I'm not sure I understand: Are suggesting there's still a further change that we should be making in CGI::Session? Mark On Sat Apr 05 13:51:22 2008, BEROV wrote: Show quoted text
> Hi, I had also this problem, but when using Storable as serializer and > MySQL for storage. > I changed the serializer to yaml and the problem was solved. > I know this is just a workaround... > > If this is of any help: > My dsn: > DBI:mysql:database=blabala;host=localhost;mysql_enable_utf8=1 > > note the 'mysql_enable_utf8=1' > > and I use also DBIx::Simple::UTF8Columns which automatically encodes the > data sent to the database. > > But Storable files/data are binary and are not supposed to be utf8
upgraded. Show quoted text
> > Since YAML dumps are just text there is no problem. > > > On Sun Mar 16 01:30:18 2008, ron@savage.net.au wrote:
> > Hi Mark > > > > On Sat, 2008-03-15 at 22:52 -0400, MARKSTOS via RT wrote:
> > > Queue: CGI-Session > > > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=21981 > > > > > > > I see there's a fix for this in SVN and some passing tests. Would
it be Show quoted text
> > > too much hassle to make this warning the test emits go away? Some
users Show quoted text
> > > could take it to indicate a problem. > > > > > > I looked at distributing Test::Warn for this purpose, but it
requires a Show quoted text
> > > string of dependencies itself. > > > > > > Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval > > > 19) line 1. > > > Can't locate package Encode::Encoding for @Encode::utf8::ISA at (eval > > > 19) line 1. > > > (in cleanup) Can't locate object method "renewed" via package > > > "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at
(eval 19) Show quoted text
> > > line 1. > > > (in cleanup) Can't locate object method "renewed" via package > > > "Encode::utf8" (perhaps you forgot to load "Encode::utf8"?) at
(eval 19) Show quoted text
> > > line 1.
> > > > My first thought was to patch the text associated with the test to add: > > > > Warnings expected. Consult docs re 'utf8' > > > > I'll do that now in SVN. > > > > Also, let me copy here for the record the rationale I posted to the > > mailing list for these warnings: > > > > <==8><==> > > The new test program I've written passes all tests, but still emits a > > deliberate warning message. Here's my thinking: > > > > o Tests and installation should not fail in all those cases people are > > not using utf8 > > > > o References to utf8 are on RT, the docs (with my patch), and this email > > list's archive, to help people diagnose problems > > > > o My new test program passes all tests so automated testing and > > installation can continue, assuming all other problems are fixed, of > > course > > > > o The new test emits a warning so anyone watching the tests' progress > > will see a reference to utf8 being problematic > > > > o Clearly I do not have a solution to this problem, but I have no > > intention of diving into the innards of utf8-related code, so I see the > > new test as simply giving people more warning about utf8 problems than > > they've had up to now > > <==8><==> > > > > Sure, users can be confused, but to me that's better than having their > > programs behave mysteriously over a known problem. > >
> >
MIME-Version: 1.0
In-Reply-To: <20061009231148.GI13185 [...] voyageur.nic.fr>
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Charset: utf8
References: <20061009231148.GI13185 [...] voyageur.nic.fr>
Content-Type: multipart/mixed; boundary="----------=_1238203205-2203-182"
Message-ID: <rt-3.6.HEAD-2203-1238203205-93.21981-0-0 [...] rt.cpan.org>
X-RT-Original-Encoding: utf-8
Content-Length: 0
Content-Disposition: inline
Content-Type: text/plain
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 112
Download (untitled) / with headers
text/plain 112b
Because there is have been no response from the requestor in the last 5 months, I'm considering this resolved.
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Type: multipart/mixed; boundary="----------=_1238203205-2203-181"
Charset: utf8
Content-Length: 0
Content-Type: text/plain
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: iso-8859-1
Content-Length: 0
Content-Type: application/octet-stream; name="."
Content-Disposition: inline; filename="."
Content-Transfer-Encoding: base64
Content-Length: 0


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.