Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 18507
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: Beyerj [...] students.uni-marburg.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)

Attachments


Subject: Bugs: Building XML::LibXML v1.58 or v1.58_1 w/ gcc 3.3 under Mac OS X 10.4 throws warnings
MIME-Version: 1.0
X-Mailer: MIME-tools 5.418 (Entity 5.418)
X-RT-Original-Encoding: utf-8
Content-Type: multipart/mixed; boundary="----------=_1144010353-28162-4"
Content-Length: 0
Content-Type: text/plain; charset="utf8"
Content-Disposition: inline
Content-Transfer-Encoding: binary
Content-Length: 2012
Download (untitled) / with headers
text/plain 1.9k
Specs: PowerMac G4/400 PCI (Oct. 1999) Mac OS X 10.4.5 (latest) w/ libxml2 v2.6.16 Apple DevTools 2.2.1 (latest) compiler gcc 4.0.1 and gcc 3.3 Perl 5.8.6 (factory/preinstalled) The default compiler in Mac OS X 10.4.x is gcc 4.0.1. Trying to build XML::LibXML with gcc 4.0.1 failed. I switched to gcc 3.3 (with gcc_select 3.3). This let the "signedness warnings" in gcc 4.0.1 disappear, but two problems are left: (1) Warning while running 'perl makefile.PL' "running xml2-config...untested WARNING! The installed version of libxml2 was not tested with this version of XML::LibXML. XML::LibXML may fail building or some tests may not pass. Expect strange errors and unstable scripts. Check the README file for more informations END OF WARNING " Well, the Readme does not say something helpfull... It's out of date. (2) Warning of deprecated DOCBparser At last, there is the following warning: /usr/include/libxml2/libxml/DOCBparser.h:22:2: warning: #warning "The DOCBparser module has been deprecated in libxml2-2.6.0" During 'make test' all tests but one passed successfully; one was skipped; none threw errors. I decided to give it a try, and started to expect strange errors and unstable scripts (because I read the Readme ;-) It's interesting to see that warning #2 has been around in XML::LibXML since Oct 2003. The compatibility of XML::LibXML with libxml2 > v2.6.0 seems questionable to me. In general, not only on the Mac. Just for the record -- this problem is not only Apple/OS X related, there are some general problems with XML::LibXML and related modules in their current states. Perl modules are expected to be platform independent, and these ones aren't. I contacted the author of XML::LibXML and related modules, Christian Glahn, a week ago and still hope to get an answer. But since this bug list grows, while there is no visible development or maintenance of XML::LibXML since two years, I fear we're all out of luck. Sad situation. Cheers Joerg
Subject: XML-LibXML-1.58_gcc33.txt
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="----------=_1144010353-28162-3"
X-Mailer: MIME-tools 5.418 (Entity 5.418)
Content-Length: 0
Content-Type: text/plain; charset="utf8"
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 0
Content-Type: text/plain; charset="utf-8"; name="XML-LibXML-1.58_gcc33.txt"
Content-Disposition: inline; filename="XML-LibXML-1.58_gcc33.txt"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: ascii
Content-Length: 11753
Last login: Sun Apr 2 16:40:50 on ttyp1 Welcome to Darwin! Nachtblauer-Tower:~ beyerjoerg$ gcc_select Current default compiler: gcc version 3.3 20030304 (Apple Computer, Inc. build 1819) Nachtblauer-Tower:~ beyerjoerg$ cd /Volumes/Perl-Stuff/XML-LibXML-1.58/ Nachtblauer-Tower:/Volumes/Perl-Stuff/XML-LibXML-1.58 beyerjoerg$ ls Changes README perl-libxml-sax.c LICENSE dom.c perl-libxml-sax.h LibXML.pm dom.h ppport.h LibXML.pod example t LibXML.xs lib typemap MANIFEST perl-libxml-mm.c xpath.c Makefile.PL perl-libxml-mm.h xpath.h Nachtblauer-Tower:/Volumes/Perl-Stuff/XML-LibXML-1.58 beyerjoerg$ perl makefile.PL enable native perl UTF8 running xml2-config...untested WARNING! The installed version of libxml2 was not tested with this version of XML::LibXML. XML::LibXML may fail building or some tests may not pass. Expect strange errors and unstable scripts. Check the README file for more informations END OF WARNING looking for -lxml2... yes Checking if your kit is complete... Looks good Writing Makefile for XML::LibXML Nachtblauer-Tower:/Volumes/Perl-Stuff/XML-LibXML-1.58 beyerjoerg$ make cp lib/XML/LibXML/DOM.pod blib/lib/XML/LibXML/DOM.pod cp lib/XML/LibXML/Number.pm blib/lib/XML/LibXML/Number.pm cp lib/XML/LibXML/SAX.pm blib/lib/XML/LibXML/SAX.pm cp lib/XML/LibXML/Literal.pm blib/lib/XML/LibXML/Literal.pm cp lib/XML/LibXML/Node.pod blib/lib/XML/LibXML/Node.pod cp lib/XML/LibXML/SAX/Builder.pm blib/lib/XML/LibXML/SAX/Builder.pm cp LibXML.pm blib/lib/XML/LibXML.pm cp lib/XML/LibXML/Parser.pod blib/lib/XML/LibXML/Parser.pod cp lib/XML/LibXML/DocumentFragment.pod blib/lib/XML/LibXML/DocumentFragment.pod cp lib/XML/LibXML/Element.pod blib/lib/XML/LibXML/Element.pod cp lib/XML/LibXML/SAX/Parser.pm blib/lib/XML/LibXML/SAX/Parser.pm cp lib/XML/LibXML/Namespace.pod blib/lib/XML/LibXML/Namespace.pod cp lib/XML/LibXML/SAX/Builder.pod blib/lib/XML/LibXML/SAX/Builder.pod cp lib/XML/LibXML/Document.pod blib/lib/XML/LibXML/Document.pod cp lib/XML/LibXML/Attr.pod blib/lib/XML/LibXML/Attr.pod cp lib/XML/LibXML/SAX/Generator.pm blib/lib/XML/LibXML/SAX/Generator.pm cp lib/XML/LibXML/CDATASection.pod blib/lib/XML/LibXML/CDATASection.pod cp LibXML.pod blib/lib/XML/LibXML.pod cp lib/XML/LibXML/SAX.pod blib/lib/XML/LibXML/SAX.pod cp lib/XML/LibXML/Text.pod blib/lib/XML/LibXML/Text.pod cp lib/XML/LibXML/Boolean.pm blib/lib/XML/LibXML/Boolean.pm cp lib/XML/LibXML/PI.pod blib/lib/XML/LibXML/PI.pod cp lib/XML/LibXML/NodeList.pm blib/lib/XML/LibXML/NodeList.pm cp lib/XML/LibXML/Comment.pod blib/lib/XML/LibXML/Comment.pod cp lib/XML/LibXML/Dtd.pod blib/lib/XML/LibXML/Dtd.pod /usr/bin/perl /System/Library/Perl/5.8.6/ExtUtils/xsubpp -typemap /System/Library/Perl/5.8.6/ExtUtils/typemap -typemap typemap LibXML.xs > LibXML.xsc && mv LibXML.xsc LibXML.c cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK LibXML.c In file included from LibXML.xs:32: /usr/include/libxml2/libxml/DOCBparser.h:22:2: warning: #warning "The DOCBparser module has been deprecated in libxml2-2.6.0" cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK dom.c cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK perl-libxml-mm.c cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK perl-libxml-sax.c cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK xpath.c Running Mkbootstrap for XML::LibXML () chmod 644 LibXML.bs rm -f blib/arch/auto/XML/LibXML/LibXML.bundle LD_RUN_PATH="/usr/lib" env MACOSX_DEPLOYMENT_TARGET=10.3 cc -bundle -undefined dynamic_lookup -L/usr/local/lib LibXML.o dom.o perl-libxml-mm.o perl-libxml-sax.o xpath.o -o blib/arch/auto/XML/LibXML/LibXML.bundle -L/usr/lib -lxml2 -lz -lpthread -liconv -lm chmod 755 blib/arch/auto/XML/LibXML/LibXML.bundle cp LibXML.bs blib/arch/auto/XML/LibXML/LibXML.bs chmod 644 blib/arch/auto/XML/LibXML/LibXML.bs Manifying blib/man3/XML::LibXML::Number.3pm Manifying blib/man3/XML::LibXML::DOM.3pm Manifying blib/man3/XML::LibXML::Node.3pm Manifying blib/man3/XML::LibXML::Literal.3pm Manifying blib/man3/XML::LibXML::Parser.3pm Manifying blib/man3/XML::LibXML::DocumentFragment.3pm Manifying blib/man3/XML::LibXML::Element.3pm Manifying blib/man3/XML::LibXML::SAX::Builder.3pm Manifying blib/man3/XML::LibXML::Namespace.3pm Manifying blib/man3/XML::LibXML::Document.3pm Manifying blib/man3/XML::LibXML::Attr.3pm Manifying blib/man3/XML::LibXML::SAX::Generator.3pm Manifying blib/man3/XML::LibXML::CDATASection.3pm Manifying blib/man3/XML::LibXML::SAX.3pm Manifying blib/man3/XML::LibXML.3pm Manifying blib/man3/XML::LibXML::Text.3pm Manifying blib/man3/XML::LibXML::Boolean.3pm Manifying blib/man3/XML::LibXML::PI.3pm Manifying blib/man3/XML::LibXML::NodeList.3pm Manifying blib/man3/XML::LibXML::Dtd.3pm Manifying blib/man3/XML::LibXML::Comment.3pm Nachtblauer-Tower:/Volumes/Perl-Stuff/XML-LibXML-1.58 beyerjoerg$ make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01basic...........ok t/02parse...........ok t/03doc.............ok t/04node............ok t/05text............ok t/06elements........ok t/07dtd.............ok t/08findnodes.......ok t/09xpath...........ok t/10ns..............ok t/11memory..........skipped all skipped: no reason given t/12html............ok t/13dtd.............ok t/14sax.............ok t/15nodelist........ok t/16docnodes........ok t/17callbacks.......ok t/18docfree.........ok t/19encoding........ok t/20extras..........ok t/23rawfunctions....ok t/24c14n............ok All tests successful, 1 test skipped. Files=22, Tests=1090, 17 wallclock secs ( 8.22 cusr + 1.42 csys = 9.64 CPU) Nachtblauer-Tower:/Volumes/Perl-Stuff/XML-LibXML-1.58 beyerjoerg$ sudo make install Password: Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/auto/XML/LibXML/LibXML.bs Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/auto/XML/LibXML/LibXML.bundle Files found in blib/arch: installing files in blib/lib into architecture dependent library tree Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Attr.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Boolean.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/CDATASection.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Comment.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Document.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/DocumentFragment.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/DOM.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Dtd.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Element.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Literal.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Namespace.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Node.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/NodeList.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Number.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Parser.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/PI.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/SAX.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/SAX.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/Text.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/SAX/Builder.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/SAX/Builder.pod Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/SAX/Generator.pm Installing /Library/Perl/5.8.6/darwin-thread-multi-2level/XML/LibXML/SAX/Parser.pm Installing /usr/local/man/man3/XML::LibXML.3pm Installing /usr/local/man/man3/XML::LibXML::Attr.3pm Installing /usr/local/man/man3/XML::LibXML::Boolean.3pm Installing /usr/local/man/man3/XML::LibXML::CDATASection.3pm Installing /usr/local/man/man3/XML::LibXML::Comment.3pm Installing /usr/local/man/man3/XML::LibXML::Document.3pm Installing /usr/local/man/man3/XML::LibXML::DocumentFragment.3pm Installing /usr/local/man/man3/XML::LibXML::DOM.3pm Installing /usr/local/man/man3/XML::LibXML::Dtd.3pm Installing /usr/local/man/man3/XML::LibXML::Element.3pm Installing /usr/local/man/man3/XML::LibXML::Literal.3pm Installing /usr/local/man/man3/XML::LibXML::Namespace.3pm Installing /usr/local/man/man3/XML::LibXML::Node.3pm Installing /usr/local/man/man3/XML::LibXML::NodeList.3pm Installing /usr/local/man/man3/XML::LibXML::Number.3pm Installing /usr/local/man/man3/XML::LibXML::Parser.3pm Installing /usr/local/man/man3/XML::LibXML::PI.3pm Installing /usr/local/man/man3/XML::LibXML::SAX.3pm Installing /usr/local/man/man3/XML::LibXML::SAX::Builder.3pm Installing /usr/local/man/man3/XML::LibXML::SAX::Generator.3pm Installing /usr/local/man/man3/XML::LibXML::Text.3pm Writing /Library/Perl/5.8.6/darwin-thread-multi-2level/auto/XML/LibXML/.packlist Appending installation info to //System/Library/Perl/5.8.6/darwin-thread-multi-2level/perllocal.pod Nachtblauer-Tower:/Volumes/Perl-Stuff/XML-LibXML-1.58 beyerjoerg$


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.