Skip Menu |
 

This queue is for tickets about the Net-IP CPAN distribution.

Report information
The Basics
Id: 12839
Status: resolved
Priority: 0/
Queue: Net-IP

People
Owner: manuel.valente [...] gmail.com
Requestors: adamk [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.21
Fixed in: 1.23



Content-Type: text/plain
Content-Disposition: inline
Content-Transfer-Encoding: binary
MIME-Version: 1.0
X-Mailer: MIME-tools 5.415 (Entity 5.415)
Subject: Incorrectly adds dependency on 5.008
X-RT-Original-Encoding: iso-8859-1
Content-Length: 587
Download (untitled) / with headers
text/plain 587b
Net::IP has a Makefile.PL dependency on perl 5.008. This is cascading down to every project that depends on it, including ThreatNet::, which otherwise is quite happily 5.006 dependant. On a perl 5.6.1 box, I removed the first line of Makefile.PL "use 5.008;" and the module could be made tested and installed without error. My conclusion is either that the 5.008 slipped in as boilerplate, or there is a bug triggered by older versions, but there is no unit test that examines it. You need to use either a more accurate version dependency, or add a unit test that will fail, or both.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.