Skip Menu |
 

This queue is for tickets about the Locale-Country-Extra CPAN distribution.

Report information
The Basics
Id: 128040
Status: new
Priority: 0/
Queue: Locale-Country-Extra

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 1.0.0
  • 1.0.2
  • 1.0.3
Fixed in: (no value)



Subject: Locale::Country will be removed from the Perl core distribution
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Message-ID: <rt-4.0.18-15455-1545116119-753.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 3621
Download (untitled) / with headers
text/plain 3.5k
With newer perls (5.28.x) the test suite may fail: ... PERL_DL_NONLAZY=1 "/opt/perl-5.28.1/bin/perl5.28.1" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t Locale::Country will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at lib/Locale/Country/Extra.pm, line 6. Locale::Codes will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm, line 22. t/00_load.t .... ok # Failed test 'no warnings' # at /opt/perl-5.28.1/lib/site_perl/5.28.1/Test/Builder.pm line 158. # There were 2 warning(s) # Previous test 0 '' # Locale::Country will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at lib/Locale/Country/Extra.pm, line 6. # at /opt/perl-5.28.1/lib/5.28.1/deprecate.pm line 61. # deprecate::import(undef, undef, "deprecate") called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # Locale::Country::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # require Locale/Country.pm called at lib/Locale/Country/Extra.pm line 6 # Locale::Country::Extra::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # require Locale/Country/Extra.pm called at t/countries.t line 7 # main::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 21 # # ---------- # Previous test 0 '' # Locale::Codes will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm, line 22. # at /opt/perl-5.28.1/lib/5.28.1/deprecate.pm line 61. # deprecate::import(undef, undef, "deprecate") called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # Locale::Codes::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # require Locale/Codes.pm called at /opt/perl-5.28.1/lib/5.28.1/Locale/Country.pm line 22 # Locale::Country::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # require Locale/Country.pm called at lib/Locale/Country/Extra.pm line 6 # Locale::Country::Extra::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # require Locale/Country/Extra.pm called at t/countries.t line 7 # main::BEGIN() called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # eval {...} called at /opt/perl-5.28.1/lib/5.28.1/Locale/Codes.pm line 15 # # Looks like you failed 1 test of 8. t/countries.t .. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/8 subtests ... Similar reports about the same issue: * AtteanX-RDFQueryTranslator-0.100 https://github.com/kasei/atteanx-rdfquerytranslator/issues/1 * App-skos2jskos-0.1.4 https://github.com/gbv/skos2jskos/issues/4 * App-wdq-0.4.4 https://github.com/nichtich/wdq/issues/30 * Experian-IDAuth-2.52 https://github.com/binary-com/perl-experian-idauth/issues/23


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.