Skip Menu |
 

This queue is for tickets about the IO-Async-SSL CPAN distribution.

Report information
The Basics
Id: 125220
Status: resolved
Priority: 0/
Queue: IO-Async-SSL

People
Owner: Nobody in particular
Requestors: richard [...] matrix.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.22



MIME-Version: 1.0
X-Spam-Status: No, score=-1.999 tagged_above=-99.9 required=10 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, SPF_FAIL=0.001] autolearn=no
X-Cpan.org: This message routed through the cpan.org mail forwarding service. Please use PAUSE pause.perl.org to configure your delivery settings.
X-Spam-Flag: NO
Content-Language: en-GB
content-type: text/plain; charset="utf-8"; format="flowed"
Message-ID: <c5d76e4e-b761-47a8-c7ce-19ba00a4e900 [...] matrix.org>
X-Virus-Scanned: Debian amavisd-new at bestpractical.com
X-Spam-Score: -1.999
Received: from localhost (localhost [127.0.0.1]) by hipster.bestpractical.com (Postfix) with ESMTP id C102224030B for <cpan-bug+IO-Async-SSL [...] hipster.bestpractical.com>; Thu, 26 Apr 2018 20:07:27 -0400 (EDT)
Received: from hipster.bestpractical.com ([127.0.0.1]) by localhost (hipster.bestpractical.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id CiV-xzkq2y9i for <cpan-bug+IO-Async-SSL [...] hipster.bestpractical.com>; Thu, 26 Apr 2018 20:07:27 -0400 (EDT)
Received: from xx1.develooper.com (xx1.develooper.com [207.171.7.115]) by hipster.bestpractical.com (Postfix) with ESMTPS id D2002240279 for <bug-IO-Async-SSL [...] rt.cpan.org>; Thu, 26 Apr 2018 20:07:26 -0400 (EDT)
Received: from localhost (xx1.develooper.com [127.0.0.1]) by localhost (Postfix) with ESMTP id 796B711DE14 for <bug-IO-Async-SSL [...] rt.cpan.org>; Thu, 26 Apr 2018 17:07:25 -0700 (PDT)
Received: from xx1.develooper.com (xx1.develooper.com [127.0.0.1]) by localhost (Postfix) with SMTP id EF3A611D9D9 for <bug-IO-Async-SSL [...] rt.cpan.org>; Thu, 26 Apr 2018 17:07:22 -0700 (PDT)
Received: from hermes.matrix.org (hermes.matrix.org [83.136.254.153]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by xx1.develooper.com (Postfix) with ESMTPS id 9D84011DEDD for <bug-IO-Async-SSL [...] rt.cpan.org>; Thu, 26 Apr 2018 17:07:16 -0700 (PDT)
Received: from [2001:8b0:ba7a:e98f:3252:cbff:fee8:6489] by hermes.matrix.org with esmtpsa (TLS1.2:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.84_2) (envelope-from <richard [...] matrix.org>) id 1fBqlJ-0003tE-1N for bug-IO-Async-SSL [...] rt.cpan.org; Thu, 26 Apr 2018 23:57:17 +0000
Authentication-Results: hipster.bestpractical.com (amavisd-new); dkim=pass header.i= [...] matrix.org
Delivered-To: cpan-bug+IO-Async-SSL [...] hipster.bestpractical.com
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0
Subject: tests fail when run against IO::Socket::SSL <= 2.002
Return-Path: <richard [...] matrix.org>
X-RT-Mail-Extension: io-async-ssl
X-Original-To: cpan-bug+IO-Async-SSL [...] hipster.bestpractical.com
Dkim-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=matrix.org; s=hermes; h=Content-Transfer-Encoding:Content-Type:MIME-Version:Date:Message-ID:Subject:From:To; bh=dNFcBeN1tQeycf7Cx2FKpV7OC5xHVQHhliH93EPpq5w=; b=hK5uR+ccg8EXybPBTgv+Om7WvtuU/K7w+yM9e3zS3EWto1oBb250WswOPAsuScuvsrtEvkIrCtztrvPJCHTgNnIYnsUjK8HHqnZKnYMW9MHCj9An7ZHtMTV/GxbdOZBJQZZniy3aWL9S0Y6OvndwscC4PDpHnSk24w+hl45LAYOcp9k1lkdpeiAeDOoFwfu0PS5Fk7j9CNO8+RFbIvZ/MeI/Y/Gsuhv86ixKGttIJKYsoVwlRm3nYdfwn84kVZVMLel4nvHEbKCXgZHgh755CTIF/QIjE4Q0t/gN+ZWLWQfl0qLBF5yrQMkjw9ImfxoK353RQf+lel5r/qcD4On4Ew==;
X-PMX-Spam: Gauge=IIIIIIII, Probability=8%, Report=' HTML_00_01 0.05, HTML_00_10 0.05, BODYTEXTP_SIZE_3000_LESS 0, BODY_SIZE_1000_LESS 0, BODY_SIZE_2000_LESS 0, BODY_SIZE_5000_LESS 0, BODY_SIZE_500_599 0, BODY_SIZE_7000_LESS 0, DKIM_SIGNATURE 0, FROM_NAME_PHRASE 0, SINGLE_URI_IN_BODY 0, SPF_PASS 0, URI_WITH_PATH_ONLY 0, __ANY_URI 0, __CP_URI_IN_BODY 0, __CT 0, __CTE 0, __CT_TEXT_PLAIN 0, __FRAUD_MONEY_DENOMINATION 0, __HAS_FROM 0, __HAS_MSGID 0, __HTTPS_URI 0, __MIME_TEXT_ONLY 0, __MIME_TEXT_P 0, __MIME_TEXT_P1 0, __MIME_VERSION 0, __MOZILLA_USER_AGENT 0, __NO_HTML_TAG_RAW 0, __SANE_MSGID 0, __SINGLE_URI_TEXT 0, __SUBJ_ALPHA_START 0, __TO_MALFORMED_2 0, __TO_NO_NAME 0, __URI_IN_BODY 0, __URI_NOT_IMG 0, __URI_NO_MAILTO 0, __URI_NO_WWW 0, __URI_NS , __URI_WITH_PATH 0, __USER_AGENT 0, __zen.spamhaus.org_ERROR '
Date: Fri, 27 Apr 2018 00:57:17 +0100
X-Spam-Level:
X-Greylist: delayed 596 seconds by postgrey-1.34 at xx1.develooper.com; Thu, 26 Apr 2018 17:07:16 PDT
X-PMX-Version: 5.6.1.2065439, Antispam-Engine: 2.7.2.376379, Antispam-Data: 2018.4.8.232716
To: bug-IO-Async-SSL [...] rt.cpan.org
Content-Transfer-Encoding: 7bit
From: Richard van der Hoff <richard [...] matrix.org>
X-RT-Original-Encoding: utf-8
X-RT-Interface: Email
Content-Length: 527
Download (untitled) / with headers
text/plain 527b
Given that this was fixed in IO::Socket::SSL 3.5 years ago, you may consider this somewhat irrelevant, but if so you may like to bump the version specifier on the 'use' directive. It's been quite a job to figure out exactly what I had to upgrade to fix my install error. Anyway, the "erroneous SSL_upgrade" test in t/01upgrade.t fails, apparently because IO::Socket::SSL used to swallow errors when the cert wasn't found, as per https://github.com/noxxi/p5-io-socket-ssl/commit/a09f29f423859565bc0384dcfbbc75811d9e4e4a.
MIME-Version: 1.0
In-Reply-To: <c5d76e4e-b761-47a8-c7ce-19ba00a4e900 [...] matrix.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <c5d76e4e-b761-47a8-c7ce-19ba00a4e900 [...] matrix.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-4215-1531762050-1301.125220-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 444
Download (untitled) / with headers
text/plain 444b
On Thu Apr 26 20:07:28 2018, richard@matrix.org wrote: Show quoted text
> Given that this was fixed in IO::Socket::SSL 3.5 years ago, you may > consider this somewhat irrelevant, but if so you may like to bump the > version specifier on the 'use' directive. It's been quite a job to > figure out exactly what I had to upgrade to fix my install error.
Oops. I bumped that and released it some time ago and just forgot to close this bug. Fixed. -- Paul Evans


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.