This queue is for tickets about the IO-Prompt CPAN distribution.

Report information
The Basics
Id:
106660
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
ppisar [...] redhat.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
0.997003
Fixed in:
(no value)



Subject: Unneeded dependency on version
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Message-ID: <rt-4.0.18-24890-1440570281-1563.0-0-0@rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 898
Makefile.PL declares run-time dependency on version module. However, this module is nowhere used. I recommend to remove it from the metadata: $ grep -Hnr version * Build.PL:9: dist_version_from => 'lib/IO/Prompt.pm', Build.PL:12: 'version' => 0, Changes:63: - Changed versioning system lib/IO/Prompt.pm:647:This document describes IO::Prompt version 0.997003 lib/IO/Prompt.pm:841:version Makefile.PL:13: 'version' => 0, META.json:7: "generated_by" : "ExtUtils::MakeMaker version 7.04, CPAN::Meta::Converter version 2.142690", META.json:13: "version" : "2" META.json:40: "version" : "0" META.json:45: "version" : "0.997003" META.yml:10:generated_by: 'ExtUtils::MakeMaker version 7.04, CPAN::Meta::Converter version 2.142690' META.yml:14: version: '1.4' META.yml:26: version: '0' META.yml:27:version: '0.997003' README:1:IO::Prompt version 0.997003
MIME-Version: 1.0
X-Spam-Status: No, score=-5.919 tagged_above=-99.9 required=10 tests=[AWL=0.679, BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, FREEMAIL_FROM=0.001, FROM_OUR_RT=-4, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7] autolearn=ham
In-Reply-To: <rt-4.0.18-24890-1440570281-817.106660-4-0@rt.cpan.org>
X-Spam-Flag: NO
X-RT-Interface: API
References: <RT-Ticket-106660@rt.cpan.org> <rt-4.0.18-24890-1440570281-817.106660-4-0@rt.cpan.org>
X-Virus-Scanned: Debian amavisd-new at bestpractical.com
X-Received: by 10.107.28.209 with SMTP id c200mr1694833ioc.90.1440574958150; Wed, 26 Aug 2015 00:42:38 -0700 (PDT)
Message-ID: <CAATtAp5kR2HzJ3GC_F9YRf-gRcATSbCvVe8bPEFVbiqny8qY0Q@mail.gmail.com>
Content-Type: multipart/alternative; boundary="001a11408a7aa72810051e31fe9c"
X-Spam-Score: -5.919
Authentication-Results: hipster.bestpractical.com (amavisd-new); dkim=pass header.i=@gmail.com
Received: from localhost (localhost [127.0.0.1]) by hipster.bestpractical.com (Postfix) with ESMTP id CC117240334 for <cpan-bug+IO-Prompt@hipster.bestpractical.com>; Wed, 26 Aug 2015 03:42:45 -0400 (EDT)
Received: from hipster.bestpractical.com ([127.0.0.1]) by localhost (hipster.bestpractical.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id tLejJPhuQPQ3 for <cpan-bug+IO-Prompt@hipster.bestpractical.com>; Wed, 26 Aug 2015 03:42:44 -0400 (EDT)
Received: from la.mx.develooper.com (x1.develooper.com [207.171.7.70]) by hipster.bestpractical.com (Postfix) with SMTP id 4C9292402E7 for <bug-IO-Prompt@rt.cpan.org>; Wed, 26 Aug 2015 03:42:44 -0400 (EDT)
Received: (qmail 32235 invoked by alias); 26 Aug 2015 07:42:43 -0000
Received: from mail-io0-f177.google.com (HELO mail-io0-f177.google.com) (209.85.223.177) by la.mx.develooper.com (qpsmtpd/0.28) with ESMTP; Wed, 26 Aug 2015 00:42:41 -0700
Received: by iodv127 with SMTP id v127so9049100iod.3 for <bug-IO-Prompt@rt.cpan.org>; Wed, 26 Aug 2015 00:42:38 -0700 (PDT)
Received: by 10.79.39.135 with HTTP; Wed, 26 Aug 2015 00:41:58 -0700 (PDT)
Delivered-To: cpan-bug+IO-Prompt@hipster.bestpractical.com
Subject: Re: [rt.cpan.org #106660] Unneeded dependency on version
Return-Path: <thoughtstream@gmail.com>
Dkim-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:sender:in-reply-to:references:from:date:message-id :subject:to:content-type; bh=5WR/wYOyVTGmIf8pQyh3+VmjQR9aaya7zHgI+u+PnAU=; b=mm7kVut6UDvp2mMdNQHHu2MQl+K/GZbUj6+FvKkyYyq8eri/CmdokLW5aNlrElIOMC tAIX9CA3/sYiQr3IL1mzgbHvfuta5wrEDjZvngdWflUWD5v5Zd7Ur0dYb89m//TcOop4 z/+6EgY0XacbwEYKHcn2Gr2D+zxFp03hWQFsFRPvrUS6JQiaIp+MVzY65tpB6XmmYT24 LRQIrndYuh4xtUE/XDbxRmNXlEPhm8JOf36jctDDJAu1hIcblK18VBRYtbKTlMNZIHpz m7jDSFY7673XW4HvPZDNZTgTWUtdZiklBagnc/6ccT3mc9iy4L4T3oM78ceqg2uSCdy9 joFQ==
X-Spam-Check-BY: la.mx.develooper.com
X-Original-To: cpan-bug+IO-Prompt@hipster.bestpractical.com
X-RT-Mail-Extension: io-prompt
X-Google-Sender-Auth: uYmmHmANEZD2hpou0Df82ExmvzM
Sender: thoughtstream@gmail.com
Date: Wed, 26 Aug 2015 17:41:58 +1000
X-Spam-Level:
To: bug-IO-Prompt@rt.cpan.org
From: Damian Conway <damian@conway.org>
RT-Message-ID: <rt-4.0.18-24890-1440574966-502.106660-0-0@rt.cpan.org>
Content-Length: 0
content-type: text/plain; charset="utf-8"
X-RT-Original-Encoding: utf-8
Content-Length: 167
content-type: text/html; charset="utf-8"
X-RT-Original-Encoding: utf-8
Content-Length: 254
Thanks, Petr.

However, this module is no longer under active maintance,
so no further changes are likely, except for urgent problems
like the /dev/tty issue.

Damian


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.