Skip Menu |
 

This queue is for tickets about the Encode CPAN distribution.

Report information
The Basics
Id: 100427
Status: resolved
Priority: 0/
Queue: Encode

People
Owner: Nobody in particular
Requestors: ppisar [...] redhat.com
Cc: pali [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.64
Fixed in: (no value)

Attachments
0001-Propagate-fatal-errors-from-the-encoding-pragma-back.patch



Subject: use encoding "foo", Filter=>1; does not raise an exception if Filter::Util::Call cannot be used
MIME-Version: 1.0
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
Message-ID: <rt-4.0.18-13489-1416323890-18.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 2010
Download (untitled) / with headers
text/plain 1.9k
Running Encode tests without Filter::Util::Call module available in the system makes t/jperl.t to fail: $ perl -Iblib/{lib,arch} t/jperl.t 1..15 Unrecognized character \x{fffd}; marked by <-- HERE after our $<-- HERE near column 10 at t/jperl.t line 90. # Looks like your test exited with 2 before it could output anything. The test does: { use encoding "euc-jp", Filter=>1; ok(1, "Filter on"); use utf8; no strict 'vars'; # fools # doesn't work w/ "my" as of this writing. # because of buggy strict.pm and utf8.pm our $人 = 2; # ^^U+4eba, "human" in CJK ideograph $人++; # a child is born *people = \$人; is ($people, 3, "Filter:utf8 identifier"); no encoding; ok(1, "Filter off"); } Obviously the first ok() is there to confirm the "use encoding ..., Filter=>1" pragma succeeded. However the encoding.pm does: unless ( $arg{Filter} ) { ... } else { defined( ${^ENCODING} ) and undef ${^ENCODING}; # implicitly 'use utf8' require utf8; # to fetch $utf8::hint_bits; $^H |= $utf8::hint_bits; eval { require Filter::Util::Call; Filter::Util::Call->import; filter_add( sub { my $status = filter_read(); if ( $status > 0 ) { $_ = $enc->decode( $_, 1 ); DEBUG and warn $_; } $status; } ); }; $@ eq '' and DEBUG and warn "Filter installed"; } The code hides any exception by the eval, so the above-mentioned first test should succeed all the time. I know the "use encoding" is deprecated, so I do not push for working on this issue or changing behavior. I'm just curious why the encode.pm does pass the exception. (This can be handy if the character set identifier is uknown or the source byte stream is not well-formed for the specified character set.)
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-13489-1416323890-18.0-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-4.0.18-13489-1416323890-18.0-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-27303-1417076040-79.100427-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 2205
Download (untitled) / with headers
text/plain 2.1k
The logic therein was written circa 2001. Even I don't remember. At any rate now that Unicode is de-facto standard for new scripts to be written, encoding.pm is no longer needed… Dan On Tue Nov 18 10:18:10 2014, ppisar wrote: Show quoted text
> Running Encode tests without Filter::Util::Call module available in > the system makes t/jperl.t to fail: > > $ perl -Iblib/{lib,arch} t/jperl.t > 1..15 > Unrecognized character \x{fffd}; marked by <-- HERE after our $<-- > HERE near column 10 at t/jperl.t line 90. > # Looks like your test exited with 2 before it could output anything. > > The test does: > > { > use encoding "euc-jp", Filter=>1; > ok(1, "Filter on"); > use utf8; > no strict 'vars'; # fools > # doesn't work w/ "my" as of this writing. > # because of buggy strict.pm and utf8.pm > our $人 = 2; > # ^^U+4eba, "human" in CJK ideograph > $人++; # a child is born > *people = \$人; > is ($people, 3, "Filter:utf8 identifier"); > no encoding; > ok(1, "Filter off"); > } > > Obviously the first ok() is there to confirm the "use encoding ..., > Filter=>1" pragma succeeded. However the encoding.pm does: > > unless ( $arg{Filter} ) { > ... > } > else { > defined( ${^ENCODING} ) and undef ${^ENCODING}; > > # implicitly 'use utf8' > require utf8; # to fetch $utf8::hint_bits; > $^H |= $utf8::hint_bits; > eval { > require Filter::Util::Call; > Filter::Util::Call->import; > filter_add( > sub { > my $status = filter_read(); > if ( $status > 0 ) { > $_ = $enc->decode( $_, 1 ); > DEBUG and warn $_; > } > $status; > } > ); > }; > $@ eq '' and DEBUG and warn "Filter installed"; > } > > The code hides any exception by the eval, so the above-mentioned first > test should succeed all the time. > > I know the "use encoding" is deprecated, so I do not push for working > on this issue or changing behavior. I'm just curious why the encode.pm > does pass the exception. (This can be handy if the character set > identifier is uknown or the source byte stream is not well-formed for > the specified character set.)
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-27303-1417076040-79.100427-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <rt-4.0.18-13489-1416323890-18.0-0-0 [...] rt.cpan.org> <rt-4.0.18-27303-1417076040-79.100427-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-15189-1496393106-268.100427-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 2958
Download (untitled) / with headers
text/plain 2.8k
That code should not be executed in eval, but rather directly with throwing exceptions back to that caller. "use encoding" must ensure that used filter is installed and used. Otherwise it is fatal error as following code is written in different encoding... Dan, will you fix it and remove eval wrapper? 'use encoding' is removed in Perl 5.26, but not 'use encoding, Filter' which is still working. See: https://metacpan.org/pod/release/XSAWYERX/perl-5.26.0/pod/perldelta.pod#The-${^ENCODING}-facility-has-been-removed Therefore Filter encoding should be fixed. On Thu Nov 27 03:14:00 2014, DANKOGAI wrote: Show quoted text
> The logic therein was written circa 2001. Even I don't remember. At > any rate now that Unicode is de-facto standard for new scripts to be > written, encoding.pm is no longer needed… > > Dan > > On Tue Nov 18 10:18:10 2014, ppisar wrote:
> > Running Encode tests without Filter::Util::Call module available in > > the system makes t/jperl.t to fail: > > > > $ perl -Iblib/{lib,arch} t/jperl.t > > 1..15 > > Unrecognized character \x{fffd}; marked by <-- HERE after our > > $<-- > > HERE near column 10 at t/jperl.t line 90. > > # Looks like your test exited with 2 before it could output anything. > > > > The test does: > > > > { > > use encoding "euc-jp", Filter=>1; > > ok(1, "Filter on"); > > use utf8; > > no strict 'vars'; # fools > > # doesn't work w/ "my" as of this writing. > > # because of buggy strict.pm and utf8.pm > > our $人 = 2; > > # ^^U+4eba, "human" in CJK ideograph > > $人++; # a child is born > > *people = \$人; > > is ($people, 3, "Filter:utf8 identifier"); > > no encoding; > > ok(1, "Filter off"); > > } > > > > Obviously the first ok() is there to confirm the "use encoding ..., > > Filter=>1" pragma succeeded. However the encoding.pm does: > > > > unless ( $arg{Filter} ) { > > ... > > } > > else { > > defined( ${^ENCODING} ) and undef ${^ENCODING}; > > > > # implicitly 'use utf8' > > require utf8; # to fetch $utf8::hint_bits; > > $^H |= $utf8::hint_bits; > > eval { > > require Filter::Util::Call; > > Filter::Util::Call->import; > > filter_add( > > sub { > > my $status = filter_read(); > > if ( $status > 0 ) { > > $_ = $enc->decode( $_, 1 ); > > DEBUG and warn $_; > > } > > $status; > > } > > ); > > }; > > $@ eq '' and DEBUG and warn "Filter installed"; > > } > > > > The code hides any exception by the eval, so the above-mentioned > > first > > test should succeed all the time. > > > > I know the "use encoding" is deprecated, so I do not push for working > > on this issue or changing behavior. I'm just curious why the > > encode.pm > > does pass the exception. (This can be handy if the character set > > identifier is uknown or the source byte stream is not well-formed for > > the specified character set.)
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-15189-1496393106-268.100427-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
X-RT-Interface: Web
References: <rt-4.0.18-13489-1416323890-18.0-0-0 [...] rt.cpan.org> <rt-4.0.18-27303-1417076040-79.100427-0-0 [...] rt.cpan.org> <rt-4.0.18-15189-1496393106-268.100427-0-0 [...] rt.cpan.org>
Content-Type: multipart/mixed; boundary="----------=_1506688536-19317-2"
Message-ID: <rt-4.0.18-19317-1506688536-690.100427-0-0 [...] rt.cpan.org>
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 0
Content-Disposition: inline
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 3306
Download (untitled) / with headers
text/plain 3.2k
In attachment is a patch with proposed fix. ppisar, can you test this patch if it fixes problem which you reported? On Fri Jun 02 04:45:06 2017, PALI wrote: Show quoted text
> That code should not be executed in eval, but rather directly with > throwing exceptions back to that caller. "use encoding" must ensure > that used filter is installed and used. Otherwise it is fatal error as > following code is written in different encoding... > > Dan, will you fix it and remove eval wrapper? 'use encoding' is > removed in Perl 5.26, but not 'use encoding, Filter' which is still > working. See: https://metacpan.org/pod/release/XSAWYERX/perl- > 5.26.0/pod/perldelta.pod#The-${^ENCODING}-facility-has-been-removed > > Therefore Filter encoding should be fixed. > > On Thu Nov 27 03:14:00 2014, DANKOGAI wrote:
> > The logic therein was written circa 2001. Even I don't remember. At > > any rate now that Unicode is de-facto standard for new scripts to be > > written, encoding.pm is no longer needed… > > > > Dan > > > > On Tue Nov 18 10:18:10 2014, ppisar wrote:
> > > Running Encode tests without Filter::Util::Call module available in > > > the system makes t/jperl.t to fail: > > > > > > $ perl -Iblib/{lib,arch} t/jperl.t > > > 1..15 > > > Unrecognized character \x{fffd}; marked by <-- HERE after our > > > $<-- > > > HERE near column 10 at t/jperl.t line 90. > > > # Looks like your test exited with 2 before it could output > > > anything. > > > > > > The test does: > > > > > > { > > > use encoding "euc-jp", Filter=>1; > > > ok(1, "Filter on"); > > > use utf8; > > > no strict 'vars'; # fools > > > # doesn't work w/ "my" as of this writing. > > > # because of buggy strict.pm and utf8.pm > > > our $人 = 2; > > > # ^^U+4eba, "human" in CJK ideograph > > > $人++; # a child is born > > > *people = \$人; > > > is ($people, 3, "Filter:utf8 identifier"); > > > no encoding; > > > ok(1, "Filter off"); > > > } > > > > > > Obviously the first ok() is there to confirm the "use encoding ..., > > > Filter=>1" pragma succeeded. However the encoding.pm does: > > > > > > unless ( $arg{Filter} ) { > > > ... > > > } > > > else { > > > defined( ${^ENCODING} ) and undef ${^ENCODING}; > > > > > > # implicitly 'use utf8' > > > require utf8; # to fetch $utf8::hint_bits; > > > $^H |= $utf8::hint_bits; > > > eval { > > > require Filter::Util::Call; > > > Filter::Util::Call->import; > > > filter_add( > > > sub { > > > my $status = filter_read(); > > > if ( $status > 0 ) { > > > $_ = $enc->decode( $_, 1 ); > > > DEBUG and warn $_; > > > } > > > $status; > > > } > > > ); > > > }; > > > $@ eq '' and DEBUG and warn "Filter installed"; > > > } > > > > > > The code hides any exception by the eval, so the above-mentioned > > > first > > > test should succeed all the time. > > > > > > I know the "use encoding" is deprecated, so I do not push for > > > working > > > on this issue or changing behavior. I'm just curious why the > > > encode.pm > > > does pass the exception. (This can be handy if the character set > > > identifier is uknown or the source byte stream is not well-formed > > > for > > > the specified character set.)
MIME-Version: 1.0
Subject: 0001-Propagate-fatal-errors-from-the-encoding-pragma-back.patch
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Type: text/x-diff; name="0001-Propagate-fatal-errors-from-the-encoding-pragma-back.patch"
Content-Disposition: inline; filename="0001-Propagate-fatal-errors-from-the-encoding-pragma-back.patch"
Content-Transfer-Encoding: binary
Content-Length: 1837
From 020c0a8a6e9a3858d78c672e59e1f6babfd5627f Mon Sep 17 00:00:00 2001 From: Pali <pali@cpan.org> Date: Fri, 29 Sep 2017 14:31:33 +0200 Subject: [PATCH] Propagate fatal errors from the encoding pragma back to the caller In some cases (e.g. when Filter::Util::Call module is not available), encoding pragma would not work. So caller should get fatal error message instead of continuous execution of the wrong code. --- encoding.pm | 12 ++---------- 1 file changed, 2 insertions(+), 10 deletions(-) diff --git a/encoding.pm b/encoding.pm index 7cd9eb2..651a158 100644 --- a/encoding.pm +++ b/encoding.pm @@ -176,7 +176,7 @@ sub import { # implicitly 'use utf8' require utf8; # to fetch $utf8::hint_bits; $^H |= $utf8::hint_bits; - eval { + require Filter::Util::Call; Filter::Util::Call->import; filter_add( @@ -189,8 +189,6 @@ sub import { $status; } ); - 1; - } and DEBUG and warn "Filter installed"; } defined ${^UNICODE} and ${^UNICODE} != 0 and return 1; for my $h (qw(STDIN STDOUT)) { @@ -200,20 +198,14 @@ sub import { Carp::croak( "encoding: Unknown encoding for $h, '$arg{$h}'"); } - eval { binmode( $h, ":raw :encoding($arg{$h})" ) }; + binmode( $h, ":raw :encoding($arg{$h})" ); } else { unless ( exists $arg{$h} ) { - eval { no warnings 'uninitialized'; binmode( $h, ":raw :encoding($name)" ); - }; } } - if ($@) { - require Carp; - Carp::croak($@); - } } return 1; # I doubt if we need it, though } -- 2.11.0
X-Scanned-BY: MIMEDefang 2.79 on 10.5.11.13
MIME-Version: 1.0
X-Spam-Status: No, score=-7.998 tagged_above=-99.9 required=10 tests=[AWL=-2.098, BAYES_00=-1.9, FROM_OUR_RT=-4] autolearn=ham
X-Authentication-Warning: dhcp-0-146.brq.redhat.com: petr set sender to ppisar [...] redhat.com using -f
In-Reply-To: <rt-4.0.18-19317-1506688536-1695.100427-6-0 [...] rt.cpan.org>
Content-Disposition: inline
X-Cpan.org: This message routed through the cpan.org mail forwarding service. Please use PAUSE pause.perl.org to configure your delivery settings.
X-Spam-Flag: NO
X-RT-Interface: API
Dmarc-Filter: OpenDMARC Filter v1.3.2 mx1.redhat.com 246C6883BB
References: <RT-Ticket-100427 [...] rt.cpan.org> <rt-4.0.18-13489-1416323890-18.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-27303-1417076040-79.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-15189-1496393106-268.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-19317-1506688536-1695.100427-6-0 [...] rt.cpan.org>
X-Virus-Scanned: Debian amavisd-new at bestpractical.com
Message-ID: <20170929131557.GB2628 [...] dhcp-0-146.brq.redhat.com>
content-type: text/plain; charset="utf-8"
X-RT-Original-Encoding: utf-8
X-Spam-Score: -7.998
Authentication-Results: ext-mx02.extmail.prod.ext.phx2.redhat.com; dmarc=none (p=none dis=none) header.from=redhat.com
Authentication-Results: ext-mx02.extmail.prod.ext.phx2.redhat.com; spf=fail smtp.mailfrom=ppisar [...] redhat.com
Received: from localhost (localhost [127.0.0.1]) by hipster.bestpractical.com (Postfix) with ESMTP id 2A6A52401F4 for <cpan-bug+Encode [...] hipster.bestpractical.com>; Fri, 29 Sep 2017 09:15:59 -0400 (EDT)
Received: from hipster.bestpractical.com ([127.0.0.1]) by localhost (hipster.bestpractical.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id JRAwqzLgWfWV for <cpan-bug+Encode [...] hipster.bestpractical.com>; Fri, 29 Sep 2017 09:15:57 -0400 (EDT)
Received: from xx1.develooper.com (xx1.develooper.com [207.171.7.115]) by hipster.bestpractical.com (Postfix) with ESMTPS id 003B024015E for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 09:15:55 -0400 (EDT)
Received: from localhost (xx1.develooper.com [127.0.0.1]) by localhost (Postfix) with ESMTP id 5E49811DA0A for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 06:15:54 -0700 (PDT)
Received: from xx1.develooper.com (xx1.develooper.com [127.0.0.1]) by localhost (Postfix) with SMTP id 89B2111EF2D for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 06:15:51 -0700 (PDT)
Received: from mx1.redhat.com (mx1.redhat.com [209.132.183.28]) (using TLSv1 with cipher ADH-AES256-SHA (256/256 bits)) (No client certificate requested) by xx1.develooper.com (Postfix) with ESMTPS id E48E111EB0C for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 06:15:37 -0700 (PDT)
Received: from smtp.corp.redhat.com (int-mx03.intmail.prod.int.phx2.redhat.com [10.5.11.13]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by mx1.redhat.com (Postfix) with ESMTPS id 246C6883BB for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 13:15:31 +0000 (UTC)
Received: from dhcp-0-146.brq.redhat.com (unknown [10.43.2.15]) by smtp.corp.redhat.com (Postfix) with ESMTPS id E903D60600 for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 13:15:30 +0000 (UTC)
Received: from dhcp-0-146.brq.redhat.com (localhost.localdomain [127.0.0.1]) by dhcp-0-146.brq.redhat.com (8.15.2/8.15.2) with ESMTP id v8TDFwnj008893 for <bug-Encode [...] rt.cpan.org>; Fri, 29 Sep 2017 15:15:58 +0200
Received: (from petr [...] localhost) by dhcp-0-146.brq.redhat.com (8.15.2/8.15.2/Submit) id v8TDFwIh008892 for bug-Encode [...] rt.cpan.org; Fri, 29 Sep 2017 15:15:58 +0200
Delivered-To: cpan-bug+Encode [...] hipster.bestpractical.com
Subject: Re: [rt.cpan.org #100427] use encoding "foo", Filter=>1; does not raise an exception if Filter::Util::Call cannot be used
User-Agent: Mutt/1.9.1 (2017-09-22)
Return-Path: <ppisar [...] redhat.com>
X-Original-To: cpan-bug+Encode [...] hipster.bestpractical.com
X-RT-Mail-Extension: encode
Date: Fri, 29 Sep 2017 15:15:58 +0200
X-PMX-Spam: Gauge=IIIIIIII, Probability=8%, Report=' HTML_00_01 0.05, HTML_00_10 0.05, SUPERLONG_LINE 0.05, BODYTEXTP_SIZE_3000_LESS 0, BODY_SIZE_1000_1099 0, BODY_SIZE_2000_LESS 0, BODY_SIZE_5000_LESS 0, BODY_SIZE_7000_LESS 0, IN_REP_TO 0, LEGITIMATE_SIGNS 0, MSG_THREAD 0, NO_URI_HTTPS 0, REFERENCES 0, SPF_PASS 0, __ANY_URI 0, __BOUNCE_CHALLENGE_SUBJ 0, __BOUNCE_NDR_SUBJ_EXEMPT 0, __CD 0, __CT 0, __CT_TEXT_PLAIN 0, __FRAUD_MONEY_CURRENCY 0, __FRAUD_MONEY_CURRENCY_DOLLAR 0, __HAS_FROM 0, __HAS_MSGID 0, __IN_REP_TO 0, __MIME_TEXT_ONLY 0, __MIME_TEXT_P 0, __MIME_TEXT_P1 0, __MIME_VERSION 0, __NO_HTML_TAG_RAW 0, __REFERENCES 0, __SANE_MSGID 0, __SUBJ_ALPHA_END 0, __SUBJ_ALPHA_NEGATE 0, __SXL_SIG_ERROR_SERVFAIL , __TO_MALFORMED_2 0, __TO_NAME 0, __TO_NAME_DIFF_FROM_ACC 0, __TO_REAL_NAMES 0, __URI_NO_MAILTO 0, __URI_NO_WWW 0, __URI_NS , __USER_AGENT 0, __zen.spamhaus.org_ERROR '
X-Spam-Level:
X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.26]); Fri, 29 Sep 2017 13:15:31 +0000 (UTC)
X-PMX-Version: 5.6.1.2065439, Antispam-Engine: 2.7.2.376379, Antispam-Data: 2017.9.29.125116
To: Pali via RT <bug-Encode [...] rt.cpan.org>
From: Petr Pisar <ppisar [...] redhat.com>
RT-Message-ID: <rt-4.0.18-19317-1506690959-882.100427-0-0 [...] rt.cpan.org>
Content-Length: 1041
On Fri, Sep 29, 2017 at 08:35:37AM -0400, Pali via RT wrote: Show quoted text
> In attachment is a patch with proposed fix. ppisar, can you test this patch > if it fixes problem which you reported? >
Latest Encode-2.92 skips the test on Perl 5.26. When I run the test on different host with Perl 5.22.3, I can reproduce the bug and after applying your patch, the test fails with expected error now: $ perl -Iblib/{lib,arch} t/jperl.t 1..15 Can't locate Filter/Util/Call.pm in @INC (you may need to install the Filter::Util::Call module) (@INC contains: blib/lib blib/arch /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at blib/lib/encoding.pm line 180. BEGIN failed--compilation aborted at t/jperl.t line 88. # Looks like your test exited with 2 before it could output anything. So I think it fixes the problem. Next step could be adding a dependency on Filter::Util::Call into META. Thank you for looking into this issue. -- Petr
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-19317-1506690959-882.100427-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <RT-Ticket-100427 [...] rt.cpan.org> <rt-4.0.18-13489-1416323890-18.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-27303-1417076040-79.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-15189-1496393106-268.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-19317-1506688536-1695.100427-6-0 [...] rt.cpan.org> <20170929131557.GB2628 [...] dhcp-0-146.brq.redhat.com> <rt-4.0.18-19317-1506690959-882.100427-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-3248-1506691286-1388.100427-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 1512
Download (untitled) / with headers
text/plain 1.4k
On Fri Sep 29 09:16:00 2017, ppisar wrote: Show quoted text
> On Fri, Sep 29, 2017 at 08:35:37AM -0400, Pali via RT wrote:
> > In attachment is a patch with proposed fix. ppisar, can you test this > > patch > > if it fixes problem which you reported? > >
> Latest Encode-2.92 skips the test on Perl 5.26. When I run the test on > different host with Perl 5.22.3, I can reproduce the bug and after > applying > your patch, the test fails with expected error now: > > $ perl -Iblib/{lib,arch} t/jperl.t 1..15 > Can't locate Filter/Util/Call.pm in @INC (you may need to install the > Filter::Util::Call module) (@INC contains: blib/lib blib/arch > /usr/local/lib64/perl5 /usr/local/share/perl5 > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl > /usr/lib64/perl5 /usr/share/perl5 .) at blib/lib/encoding.pm line 180. > BEGIN failed--compilation aborted at t/jperl.t line 88. > # Looks like your test exited with 2 before it could output anything. > > So I think it fixes the problem.
Ok. Show quoted text
> Next step could be adding a dependency on Filter::Util::Call into > META.
Looking at corelist... $ corelist Filter::Util::Call Data for 2017-01-14 Filter::Util::Call was first released with perl v5.7.3 ... it tells me that Filter::Util::Call is part of perl itself since v5.7.3. So this is looks like a problem with your installation of perl, you should have Filter::Util::Call available. But adding perl 5.8 into META seems like a good idea. It should fix also problem with Filter::Util::Call.
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-3248-1506691286-1388.100427-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <RT-Ticket-100427 [...] rt.cpan.org> <rt-4.0.18-13489-1416323890-18.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-27303-1417076040-79.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-15189-1496393106-268.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-19317-1506688536-1695.100427-6-0 [...] rt.cpan.org> <20170929131557.GB2628 [...] dhcp-0-146.brq.redhat.com> <rt-4.0.18-19317-1506690959-882.100427-0-0 [...] rt.cpan.org> <rt-4.0.18-3248-1506691286-1388.100427-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-6045-1506774511-1440.100427-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 1196
Download (untitled) / with headers
text/plain 1.1k
On Pia Sep 29 09:21:26 2017, PALI wrote: Show quoted text
> On Fri Sep 29 09:16:00 2017, ppisar wrote:
> > On Fri, Sep 29, 2017 at 08:35:37AM -0400, Pali via RT wrote:
> > > In attachment is a patch with proposed fix. ppisar, can you test > > > this > > > patch > > > if it fixes problem which you reported? > > >
> > Latest Encode-2.92 skips the test on Perl 5.26. When I run the test > > on > > different host with Perl 5.22.3, I can reproduce the bug and after > > applying > > your patch, the test fails with expected error now: > > > > $ perl -Iblib/{lib,arch} t/jperl.t 1..15 > > Can't locate Filter/Util/Call.pm in @INC (you may need to install the > > Filter::Util::Call module) (@INC contains: blib/lib blib/arch > > /usr/local/lib64/perl5 /usr/local/share/perl5 > > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl > > /usr/lib64/perl5 /usr/share/perl5 .) at blib/lib/encoding.pm line > > 180. > > BEGIN failed--compilation aborted at t/jperl.t line 88. > > # Looks like your test exited with 2 before it could output anything. > > > > So I think it fixes the problem.
> > Ok.
I created pull request with this patch: https://github.com/dankogai/p5-encode/pull/123
MIME-Version: 1.0
In-Reply-To: <rt-4.0.18-6045-1506774511-1440.100427-0-0 [...] rt.cpan.org>
X-Mailer: MIME-tools 5.504 (Entity 5.504)
Content-Disposition: inline
X-RT-Interface: Web
References: <RT-Ticket-100427 [...] rt.cpan.org> <rt-4.0.18-13489-1416323890-18.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-27303-1417076040-79.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-15189-1496393106-268.100427-6-0 [...] rt.cpan.org> <rt-4.0.18-19317-1506688536-1695.100427-6-0 [...] rt.cpan.org> <20170929131557.GB2628 [...] dhcp-0-146.brq.redhat.com> <rt-4.0.18-19317-1506690959-882.100427-0-0 [...] rt.cpan.org> <rt-4.0.18-3248-1506691286-1388.100427-0-0 [...] rt.cpan.org> <rt-4.0.18-6045-1506774511-1440.100427-0-0 [...] rt.cpan.org>
Content-Type: text/plain; charset="utf-8"
Message-ID: <rt-4.0.18-19668-1506775519-469.100427-0-0 [...] rt.cpan.org>
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
X-RT-Encrypt: 0
X-RT-Sign: 0
Content-Length: 1338
Download (untitled) / with headers
text/plain 1.3k
Pulled. Dan the Maintainer Thereof On Sat Sep 30 08:28:31 2017, PALI wrote: Show quoted text
> On Pia Sep 29 09:21:26 2017, PALI wrote:
> > On Fri Sep 29 09:16:00 2017, ppisar wrote:
> > > On Fri, Sep 29, 2017 at 08:35:37AM -0400, Pali via RT wrote:
> > > > In attachment is a patch with proposed fix. ppisar, can you test > > > > this > > > > patch > > > > if it fixes problem which you reported? > > > >
> > > Latest Encode-2.92 skips the test on Perl 5.26. When I run the test > > > on > > > different host with Perl 5.22.3, I can reproduce the bug and after > > > applying > > > your patch, the test fails with expected error now: > > > > > > $ perl -Iblib/{lib,arch} t/jperl.t 1..15 > > > Can't locate Filter/Util/Call.pm in @INC (you may need to install the > > > Filter::Util::Call module) (@INC contains: blib/lib blib/arch > > > /usr/local/lib64/perl5 /usr/local/share/perl5 > > > /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl > > > /usr/lib64/perl5 /usr/share/perl5 .) at blib/lib/encoding.pm line > > > 180. > > > BEGIN failed--compilation aborted at t/jperl.t line 88. > > > # Looks like your test exited with 2 before it could output anything. > > > > > > So I think it fixes the problem.
> > > > Ok.
> > I created pull request with this patch: > https://github.com/dankogai/p5-encode/pull/123 >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.